1 Reply Latest reply on Jul 6, 2015 10:03 AM by David_Intel

    Slow I/O performance on Intel RS2BL080 after firmware upgrade


      Relevant hardware: RS2BL080 controller with 8 drive RAID 6 array.


      We have a server running Ubuntu 12.04 LTS, and I do my best to keep it current with security updates and such. Recently, after we upgraded the kernel the server became very unstable, usually experiencing a kernel panic every 2 to 6 hours. It occurred to me that perhaps the kernel driver and the RAID card's firmware had drifted too far apart, so a couple of weeks ago we upgraded the firmware in several steps to get to current. The stability issues have disappeared, but we're experiencing very high system loads now.


      Coincidentally, we had to replace the RAID battery unit, which I did a couple of days ago because the old battery wouldn't accept enough of a charge. After the controller did a couple of automatic learn cycles, it put the cache in WriteBack mode. A basic disk performance test gives us ~ 375 MB/s write speed on a 1 GB file.


      System loads used to be between 3 and 7 during peak times, now we're seeing loads exceeding 50 on a 1 minute basis, and around 30 on a 15 minute average.


      Is there some setting we missed? The only thing I can think of is that the person that upgraded the RAID card's firmware didn't set the card to factory defaults as in the instructions. Could this be it?


      Any help would be much appreciated.


      updated: formatting