6 Replies Latest reply on Sep 29, 2015 1:59 PM by N.Scott.Pearson

    IR remote stops working after NUC wakes from sleep

    johncarmack

      NUC i5 d54250wyk bios 0038 with Windows 8.1 and the Harmony Smart Control remote.


      I've had this bug since day 1 when I bought the NUC in December 2014, and it tooks months to locate what was causing the bug, it seems when I sometimes try to turn off my windows 8.1, it only goes into some sort of sleep. After waking from this sleep the IR driver stops working so my logitech remote doesn't work anymore. If I disable then reenable the IR Nuvoton driver in device manager, it reworks, or restarting Windows ALWAYS makes it work again.


      I've just set my Windows OS to always force shutdown even when I select sleep, but it's a pain because it takes like much longer for my NUC to turn on now.


      I've tried many BIOS versions and reinstalled the IR driver like twenty times and it doesn't fix it.


      Are you guys aware of this bug? Somehow the IR driver doesn't get correctly loaded when brought out of sleep.



        • 1. Re: IR remote stops working after NUC wakes from sleep
          hansb_intel

          Hello johncarmack,

           

          Thank you for reporting this issue, I’ll test this with this same model NUC and I’ll let you know my findings.

          • 2. Re: IR remote stops working after NUC wakes from sleep
            dougho

            I am not from Intel and I don't have a Harmony remote, but I do have that NUC and have used Microsoft Media Center remotes and Windows 8.1 without the trouble you describe on various BIOS (I have had other concerns with IR such as powering up NUC when I don't want - but those are understood).

            I am wondering if perhaps your situation has somewhat unique aspects.  For example is your Harmony remote sending some different power signal than the Microsoft Media Center remote (which sends a toggle - not a discrete on or off)?  When you say "some sort of sleep", that is what Microsoft Media Center remotes do by default if you press the remote's power button when the PC is on (it is a normal sleep).  Pressing the same power button wakes it up from sleep.  I have not tried but I assume that the default "sleep" action can be changed in Windows 8.1 Control Panel-Power Options-Choose what the power buttons do (for Sleep button you could change it to something different like Hibernate).

            I guess what I'm wondering is that if your Harmony is trying some discrete on/off code, is it possible to try some power "toggle" code instead?  Since I am unaware of any Microsoft media center remote with discrete power on/off button/code, perhaps the device driver (or whatever piece of software gets the IR code) gets confused seeing such discrete power on/off code.

            And if unclear, I have just run across these mentions of Harmony discrete power codes over the years, nothing to do with NUC - it is a more widespread Windows Media Center and/or Harmony thing.  If operations is different than discussed in those various old Harmony-Media Center threads, the added difference is that the NUC BIOS decided that it should look at IR codes when the PC is shutdown (rather than the older standard of letting it get handled by device drivers in standby).  Recent NUC BIOS have allowed disabling that "wake from S5" but when I try that I now seem to need to press the remote power button multiple times to wake from sleep.

            Update: regarding "some sort of sleep" - I do not install Intel's "Rapid Start" software which I think is something like "Away Mode" (less of a sleep, more like display off).

            • 3. Re: IR remote stops working after NUC wakes from sleep
              Chaser

              I just recently bought a NUC5PPYH and installed windows 10. I have a Microsoft Media Center Remote and IR receiver that I have used on an older HTPC. I also have a Logitech Harmony 700 remote that I programed to function like the Microsoft remote and previously used with the older HTPC. I didn't regularly use the power button, the HTPC was just always on.

               

              I am having a similar problem to the original poster. Upon initial startup, both remotes work as they should. The Power button on these remotes put the NUC to sleep. The Power buttons on either remote will also wake the computer from sleep, but after windows has finished resuming, the NUC doesn't respond to any command from either remote. I have to restart the NUC in order for it to respond to the remotes again.

               

              If the computer is running, and is responding to the IR remotes, and I manually put the computer in sleep through the Power menu, I can wake the computer with the remotes, but windows fails to respond to commands from the remotes.

               

              From a completely shutdown state, I believe that I can use the remotes to turn on the NUC, and when Windows finishes loading, it will respond to the remotes. The problem seems to be isolated to waking up from sleep. I'm not sure if I have tried from a hibernation state or not, but anytime the computer wakes from sleep, the OS will not respond to IR commands.

               

              I am using the latest bios version 043 that I downloaded from the Intel Download Center and I believe that I have installed all of the latest drivers. I don't think that I changed any of the default power/wake settings inside the bios.

               

              Thanks,

              • 4. Re: IR remote stops working after NUC wakes from sleep
                Chaser

                After some more digging/experimenting I found that if I tell the NUC to never "Sleep" and to "Hibernate" when I push the power button, sleep button, or "close the lid," then when Windows wakes up, it will respond to commands from the IR remotes. This works whether I wake the NUC using the power button on the NUC case, or the Power button on the IR remotes.

                 

                This sort of fixes my problem, except it takes a bit longer for the computer to wake from Hibernation than it does to wake from Sleep. Something is killing the IR drivers when recovering from sleep.

                 

                Thanks,

                • 5. Re: IR remote stops working after NUC wakes from sleep
                  ivanu_intel

                  We tested this unit here and is working fine with an IR remote when goes to sleep, please wait for a new BIOS version to be released that can help you solving this problems.

                   

                  You can keep checking for a new BIOS version here:

                  downloadcenter.intel.com

                  • 6. Re: IR remote stops working after NUC wakes from sleep
                    N.Scott.Pearson

                    Chaser,

                     

                    There is another report of this issue outstanding already. A fix in the BIOS is forthcoming. Keep watching for BIOS update...

                     

                    ...Scott