1 2 Previous Next 15 Replies Latest reply on Jul 24, 2015 11:44 AM by ColdfireMC

    Installing a new OS breaks UEFI boot

    ColdfireMC

      After Install FreeBSD 10.1 from a EFI memstick, my pc boot was messed up. It only boots from PXE and cd or hard disk and I can't enter to BIOS setup, even after clearing CMOS moreover, motherboard's recovery mode failed too. I managed to install fedora 21, but i can't touch EFI variables from here (it boots in normal bios mode).

       

      I booted from a windows recovery disc, and checked efi partition and nvram as many sites state. I have checked firmware entries and I realize that NVRAM has at least 10 entries(samsung notebooks failed in this way too). I suspect that this is making firmware behaves this way. Please, I need help. I need to clear EFI nvram without booting in uefi mode, from some OS. I really don't know how to make this.

      My motherboard is Intel DX79TO.

       

      Summary:

       

      I can't enter to bios setup

      I can't enter recovery or service mode

      I can't boot in UEFI mode, then I can't use "efibootmgr" from OS'es like Linux

      Windows rescue disc boots in bios mode, and it can't clear NVRAM in the usual way (https://technet.microsoft.com/es-es/library/cc749510(v=ws.10).aspx)

       

      Please, I need help desperately

        • 1. Re: Installing a new OS breaks UEFI boot
          ColdfireMC

          update: I managed to remove entires with a windows PE CD. Removed a lot of expired entries but I left the fimware's main entry an the windows' one... but nothing i'm still botting directly to os or PXE, UEFI boot is completely broken. Also reflashed my bios using DOS method and recovery method, none of them corrected the problem. Rear red button and motherboard jumper are not working neither.

          Is this a bios design bug? do I need to Return this desktop board?

          Reading this forum I have noticed that problems like this, are not uncommon, neither of them were fixed with a standard method or success. Are you working to fix this, or you are just waiting to warranty expires?
          Intel desktopboards are nice, but silly issues like this one make me to want my money back.

           

          Please answer something

          • 2. Re: Installing a new OS breaks UEFI boot
            kevin_intel

            Please provide me with the following information:

             

            Motherboard AA Number:

            Memory part number:

            Current BIOS version installed:

             

             

            You mentioned different problems on Linux but can you please try all these steps in Windows Operating System. Also, it would be very good to know step by step how you are doing it and what steps you are taking.

             

            Kevin M

            • 3. Re: Installing a new OS breaks UEFI boot
              ColdfireMC

              Kevin

               

              Well I will tell the whole story:
              Initially, There was 2 disks and 650 bios version. One with a Windows 8.1 EFI boot type, the other, with Fedora 21 (EFI boot too). I used to boot one of these OS with the GRUB bootloader (EFI version). The EFI stuff was stored in a single partition in the first disk. However, this Saturday I decided to Install the FreeBSD OS (with EFI too). So I formatted the Fedora drive, Installed FreeBSD, but it not added its own boot entry, so I rebooted and Used the Windows 8.1 setup DVD to use it's windows PE environment, and erased and rebuilt the EFI partition (I previously did the same a lot of times, there's nothing new or unknown here) everything normal when once rebooted, but Instead of the windows logo, the PXE boot prompt appears, and then the firmware says "no boot device-press any key", pressing the key redirected me to the PXE boot rom again, and endessly the same... So I decided to reboot and I have noticed that  I can't enter to the bios setup, an then the PXE boot rom agian, so I pressed the rear red button "Recovery" but Nothing happened, the boot process still continued to the PXE boot. Then I opened the case and used the Jumper to enter to the "service mode", and nothing, computer booted in the same way. Without any hope I inserted  the widnows setup boot, and it booted! I used windows PE environment to make the typical boot repair methods (BCDboot), but none of them has effect. So I decided to reinstall windows 8.1, it booted but something was wrong. Setup displayed the following error:

              IMG_20150616_221420_burst_03.jpg


              According to the windows docs, this error occurs when the setup was booted in BIOS mode. Only a EFI Booted setup can Install an EFI booting OS, because are the only enabled to touch the EFI variables in the EFI NVRAM (Except, the windows PE environment). But things came worse, I erased the FreeBSD Stuff to make space for the windows setup, selected the other disk and One of the following errors in the image appear (note the second error)

              IMG_20150616_221451_burst_02.jpg

              (This Image it's not the actual situation of that time, this image is after I worked this around installing Fedora, I recreated some conditions, and the second error is the same) (That partition is the one from I running Linux, so I don't want to erase it right now).

               

              Finally, realized that cd bios boot still work I decided to install Fedora Again, but In bios mode, and now I'm posting from there. Here I tried to change efi variables using "efibootmgr" program, but it fails saying "efibootmgr: EFI variables are not supported on this system". Then Using windows PE, I erased some entries of the EFI boot, but nothing happened.I have reflashed using DOS and recovery method, the bios using 594 or 650 version, but nothing changed.

               


              The board numbers are:


              AA: G28805-402

              Serial: BTTO31700179


              Thanks Kevin

              • 4. Re: Installing a new OS breaks UEFI boot
                kevin_intel

                Your description is quite difficult to understand. My recommendations as first step is as much as possible to save all information you have and clean all HDDs and format them to void any problem with partitions and clean the MBRs.

                 

                Kevin

                • 6. Re: Installing a new OS breaks UEFI boot
                  ColdfireMC

                  There is. The second disk is empty and alone and its MBR cleared using the bootrec utility from windows 8.1 dvd.

                   

                  It is not booting from EFI also, and still i can't enter to bios setup even using the recovery jumper

                  • 7. Re: Installing a new OS breaks UEFI boot
                    kevin_intel

                    I am going to check this from my side and I will be back with more information.

                     

                    Kevin m

                    • 8. Re: Installing a new OS breaks UEFI boot
                      ColdfireMC

                      Could A BIOS version downgrade help? For example, flash a version that changes the SATA/Raid Firmware ?

                      • 9. Re: Installing a new OS breaks UEFI boot
                        kevin_intel

                        Hello ColdfireMC,

                         

                        I have been testing this model from my side and I was able to install the Operating System with UEFI enabled while having the BIOS version 0650.

                         

                        My recommendation at this point for you is to do a low level format in the HDD where you are trying to install the Operating System and if you get the message again during the installation, disconnect the Flash driver and reconnect it again to continue with the process.

                        • 10. Re: Installing a new OS breaks UEFI boot
                          ColdfireMC

                          kevin_intel: This board isn't booting from any flash drive. I managed to install Windows using another disk, clearing MBR's, and using only one disk. however I discovered one more issue:  I realized that motherboard is only detecting 3,1GB of Available RAM, and the rest of the ram is RESERVED! (I have 8gb, 1600mhz, Quad-Channel Installed). I also checked this on Linux and it says the same. Note that I'm Installing 64-bit Versions, (Usually this board maps 7,9GB of RAM). Despite of this, I can't see any performance or data corruption problem, everything runs fine once booted.

                           


                          • 11. Re: Installing a new OS breaks UEFI boot
                            ColdfireMC

                            In example in Linux.


                            As you can see, the four memory modules are properly detected by SPD, but only 3,1gb are usable.

                            • 12. Re: Installing a new OS breaks UEFI boot
                              kevin_intel

                              Hello ColdfireMC,

                               

                              I have been testing this from my side and I am able to install the Operating System without problems. I am running BIOS version 0650 and I have been testing mechanical drives and SSDs.

                              I have also tested the motherboard with 8GB (part number F3-1866C10D-16GSR) and it is recognizing the full memory capacity.

                               

                              Definitely there is something very wrong with your board so At this point, my recommendation is to contact our support center and if the motherboard is still under warranty, we will replace it.

                               

                              Kevin m

                              • 13. Re: Installing a new OS breaks UEFI boot
                                ColdfireMC

                                Ok Kevin, I'm on it, thanks for your time and tests.

                                 

                                 

                                One final thought

                                 

                                 

                                 

                                Probably this is just a Firmware issue but in the way that the BIOS is upgraded, it can't be corrected with an update. So, please consider to report this to the BIOS dev. team (if still exists), in order to prevent other users (and I, with a returned or repaired board) being affected by this problem. Clearly it's ridiculous that a deleted EFI partition could trigger a firmware bug/glitch like this one without an easy way to fix it.

                                 

                                 

                                 

                                Thanks again Kevin

                                • 14. Re: Installing a new OS breaks UEFI boot
                                  kevin_intel

                                  I am sorry for this issue but I will pass this information to the corresponding department.

                                  Kevin M

                                  1 2 Previous Next