4 Replies Latest reply on Oct 8, 2015 2:49 PM by SteinarN

    Updating USB 3.0 drivers from 3.0.0.34 to 3.0.5.69

    prjdmd

      Hi,

      I recently tried to update my Intel USB 3.0 drivers for my MSI Z87-GD65 motherboard from 3.0.0.34 to 3.0.5.69.  The update failed and after each reboot the run box appears to run the update again.   When I click on run nothing happens.  I used system restore to go back to 3.0.0.34 which works perfectly.  After the failed update I found a hardware item (don't know which one) that appeared in my device manager as unknown and drivers could not be found.  All hardware is connecting perfectly with the original drivers.  Has anyone else had issues with the USB 3.0 update to 3.0.5.69 for this motherboard?  I downloaded the USB 3.0 driver update from the MSI website for the Z87-GD65 board the first time I tried this and directly from Intel the second go around with identical results.  Any help is greatly appreciated.

        • 1. Re: Updating USB 3.0 drivers from 3.0.0.34 to 3.0.5.69
          hansb_intel

          Hi prjdmd,

           

          I installed the 3.0.5.69 version on a DZ87KLT-75K to see if there was any problem, but the driver installed without any problems. Maybe the files you are trying to install are corrupted, have you tried downloading the drivers from another machine then installing them? If not I suggest you give this a try.


          • 2. Re: Updating USB 3.0 drivers from 3.0.0.34 to 3.0.5.69
            prjdmd

            Thanks for your information.  I downloaded the drivers directly from Intel's driver download site so I am sure they are okay.  Of course I am using the drivers for an MSI Z87-GD65 motherboard.  Currently the USB 3.0 drivers I have are version 3.0.0.34 and they function perfectly as have all previous driver updates for the Intel USB 3.0 eXtensible host controller.   When I attempt to upgrade the USB 3.0 drivers for the Intel USB 3.0 eXtensible Host Controller through Device Manager automatic search it states the best driver is already installed.   Unfortunately trying to upgrade directly with the install program built into the 3.0.5.69 software results in failed installation and recurring request to run the install program at each reboot.  Something with the new driver system is not working well with my OS hence the reason for my question.  I guess I will have to continue to see if anyone else has an answer to my issue.  I do appreciate the response.

            • 3. Re: Updating USB 3.0 drivers from 3.0.0.34 to 3.0.5.69
              marving_intel

              Hello prjdmd,

               

              The drivers that we have available on our website are designed to be used on Intel motherboards so the functionality of them on third party systems is an unsupported practice that needs to be confirmed by the motherboard manufacturer before proceeding. Intel has partnership with several motherboard manufacturers like MSI, ASUS, ASRock, etc in order to get components like chipset, but at the end the support and drivers are provided by the motherboard manufacturer (including updates) so our best recommendation will be to contact MSI for assistance in regards of that.

               

              You can also check under "System Configuration" (by running the command "msconfig") - "Startup" and "Tools" tab and check if there is any service or program that is starting and is related to the USB driver installation program.

               

              On the link below you will have the option to search for the latest driver for your motherboard based on your operating system:


              Motherboard - The world leader in motherboard design

               

              If you need more assistance please let me know.

               

              Best regards,

               

              marving_intel

              • 4. Re: Updating USB 3.0 drivers from 3.0.0.34 to 3.0.5.69
                SteinarN

                I have a very similar problem to the op.

                 

                I have a main board, MSI B85M-G43. I have since last year had an old USB3 driver, the same as op, namely 3.0.0.34. A couple months ago I tried to update to v 3.0.5.69 via MSI live update. That try resulted in a total catastrophe as the computer switched off without warning when the install process had uninstalled the old driver and was well underway installing the new driver. The computer switched off completely suddenly, as if the power went out, and then restarted. Upon restart no usb ports whatsoever would work at all. That ment that I only could use one mose or one keyboard in the single PS2 port on this particular mainboard. Naturally this ment big trouble with troubleshooting as I had to chose between using keyboard or mouse when trying to get usb to work again. It quickly turned out that the SSD had gotten corrupted due to the sudden power failure. Due to this corruption system restore failed. Chkdsk found numerous missing file fragments and other problems with the drive, some of which could not be repaired. So, system restore was out of the question. Next I tried several times more to install the new driver, but now the installation simply failed without computer shutting down. I tried to download manually from MSI and install again, but no difference from installing via Live update. Together with the still failing/corrupted drive I had no choice but to boot up from DVD install media and restore to a two week old image I luckily had saved. After sucessfull restore to old image I tried once more updating the driver. This time I think I uninstalled old driver, then restarted, installed new driver and the exact same thing happened. Computer restarted unexpectedly and no usb ports working at all after the restart. But this time I had turned off the drive write cache so it didn't get corrupted at least. This ment that I could use system restore normally to revert the unsuccessful usb3 driver update.

                 

                So there seems to be something wrong with this driver or with a combination of this driver and other main board drivers or maybe the os itself. I have no access to other USB3 drivers inbetween this two drivers, so I have not been able to test when this fault originated. I do think that the main board had an even older USB3 driver when I bought it and that I updated to 3.0.0.34 back then.

                 

                Any suggestion on how to solve this problem is greatly appreciated.

                 

                regards

                SteinarN