7 Replies Latest reply on Jun 16, 2015 3:08 PM by PabloM_Intel

    Galileo gen 1 can't connect wifi

    liu115

      My image is clanton, and i've tried connecting to wifi for a few way, but none of them has worked....

      My wireless card is intel 5350 and I've already installed the driver. Therefore, I can see my wireless card as wlan0 in ifconfig.

      I first used iwlist and iwconfig to connect an open ap. The scanning is working, but after i connected to the ap, it failed to obtain an IP address. I didn't know why and the udhcpc only gained ip from lan.

      Then I tried wpa_suppliment by configuring the wpa_suppliment.conf for none protected ap and an ap with wpa2, also failed in gaining ip.

      I don't know why but these steps all follow the intel document.

      The last try was using the other network manager, connman. I installed connman-client from Index of /galileo using opkg install. After that, i was able to use the command connmanctl.

      But i could only see this,

      root@clanton:/etc# connmanctl

      connmanctl> enable wifi

      connmanctl> scan wifi

      connmanctl> services

      *AO Wired                { ethernet_001320ff187c_cable }

      connmanctl> technologies

      { /net/connman/technology/ethernet }

        [Name] = Wired

        [Type] = ethernet

        [Powered] = True

        [Connected] = True

        [Tethering] = False

      connmanctl>

      I was really frustrating that i've tried many ways learned from online. Their steps are really simple, but didn't work for my galileo.... I guess i must miss some details.

        • 1. Re: Galileo gen 1 can't connect wifi
          liu115

          Add a few more information,

               root@clanton:/etc# iwconfig

               wlan0     IEEE 802.11abgn  ESSID:off/any

                         Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated

                         Tx-Power=12 dBm

                         Retry  long limit:7   RTS thr:off   Fragment thr:off

                         Encryption key:off

                         Power Management:off

              root@clanton:/etc# ifconfig

              eth0      Link encap:Ethernet  HWaddr 00:13:20:FF:18:7C

                        inet addr:192.168.202.14  Bcast:192.168.202.255  Mask:255.255.255.0

                        inet6 addr: fe80::213:20ff:feff:187c/64 Scope:Link

                        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                        RX packets:19861 errors:0 dropped:0 overruns:0 frame:0

                        TX packets:12973 errors:0 dropped:0 overruns:0 carrier:0

                        collisions:0 txqueuelen:1000

                        RX bytes:6505182 (6.2 MiB)  TX bytes:5667738 (5.4 MiB)

                        Interrupt:40

           

           

              lo        Link encap:Local Loopback

                        inet addr:127.0.0.1  Mask:255.0.0.0

                        inet6 addr: ::1/128 Scope:Host

                        UP LOOPBACK RUNNING  MTU:65536  Metric:1

                        RX packets:278 errors:0 dropped:0 overruns:0 frame:0

                        TX packets:278 errors:0 dropped:0 overruns:0 carrier:0

                        collisions:0 txqueuelen:0

                        RX bytes:22617 (22.0 KiB)  TX bytes:22617 (22.0 KiB)

           

           

              wlan0     Link encap:Ethernet  HWaddr 00:16:EB:04:15:94

                        inet6 addr: fe80::216:ebff:fe04:1594/64 Scope:Link

                        UP BROADCAST MULTICAST  MTU:1500  Metric:1

                        RX packets:3 errors:0 dropped:0 overruns:0 frame:0

                        TX packets:5 errors:0 dropped:0 overruns:0 carrier:0

                        collisions:0 txqueuelen:1000

                        RX bytes:392 (392.0 B)  TX bytes:586 (586.0 B)

          • 2. Re: Galileo gen 1 can't connect wifi
            123finale

            Are you sure you have a wireless modem-router and an internet account? Sorry if it sounds like a stupid question but in computer troubleshooting I've always started with the cord plugged into the wall, sometimes we overlook the most basic things. 123finale

            • 3. Re: Galileo gen 1 can't connect wifi
              liu115

              Yes, i have. The command 'iwlist wlan0 scan' successfully output a few ssids and their informations.

              • 4. Re: Galileo gen 1 can't connect wifi
                123finale

                Do you have another PC with wifi that you could try out on it just in case it could be your wifi modem that's the problem? Sure does seem like you're suffering a lot of crap to try and get the desired end result

                • 5. Re: Galileo gen 1 can't connect wifi
                  123finale

                  I'm sorry lui15 but there is no way that you should have to make and troubleshoot that many moves just to obtain wifi. It sounds as though you're working at their (tech support) end.

                  • 6. Re: Galileo gen 1 can't connect wifi
                    liu115

                    It's ok, 123finale. I really appreciated that you tried to help me. I can see and even connect to my ap through another pc. I think I must miss something because using connmanctl technologies, something about wifi should be printed out. But comman seemed not to catch my wifi card. I guess this is the problem i don't know what cause the differences between me and other successful examples i had looked up by googling.

                    • 7. Re: Galileo gen 1 can't connect wifi
                      PabloM_Intel

                      Hi liu115,

                       

                      How are you configuring the wpa.supplicant.conf file?

                      Would you please provide me the link to the document you’re following?

                       

                      Regards,

                      PabloM_Intel