5 Replies Latest reply on Jun 13, 2015 8:15 AM by jb22

    Bricked Edison flashing from Ubilinux back to Yocto

    jb22

      I tried to flash a copy of Yocto back onto my Edison which previously had Ubilinux installed, using the flashall.sh tool. Unfortunately, it seems that this flash tool does not wipe the Edison first and this lead to a very dysfunctional linux installation - it still appeared to be Ubilinux but the majority of /bin commands missing.

       

      I've been experiencing the issue of not being able to view the Edison's file system through Ubuntu over usb also, which hasn't helped. After many rounds of attempts to reflash (sometimes with --recovery using xfstk), I'm now in a state where I can no longer flash at all successfully, and my boot log over serial looks like:

       

      ******************************

      PSH KERNEL VERSION: b0182b2b

                      WR: 20104000

      ******************************

      SCU IPC: 0x800000d0  0xfffce92c

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

      microkernel built 11:24:08 Feb  5 2015

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

      *** Ready to receive application ***

       

       

      U-Boot 2014.04 (Jun 11 2015 - 02:36:24)

       

      Watchdog enabled

      DRAM:  980.6 MiB

      MMC:   tangier_sdhci: 0

      In:    serial

      Out:   serial

      Err:   serial

      Hit any key to stop autoboot:  0

      boot >

      boot > run do_flash

      Saving Environment to MMC...

      Writing to redundant MMC(0)... done

      GADGET DRIVER: usb_dnl_dfu

       

       

      It hands indefinitely here until I send the ctrl-c interrupt, which triggers a reboot:

       

      Unknown boot mode: boot

      Saving Environment to MMC...

      Writing to MMC(0)... done

      Resetting to default boot mode and reboot...

      resetting ...

       

       

      I've tried interrupting the boot and typing 'run do_flash', but this hasn't helped. How can I truly wipe everything on the Edison and flash everything anew?

       

      All help greatly appreciated! I haven't had my Edison very long, and would probably just go back to the rpi if I cannot fix it.

        • 1. Re: Bricked Edison flashing from Ubilinux back to Yocto
          CMata_Intel

          Hi jb22

           

          Let's try with the Flash Tool Lite: Flash Tool Lite User Manual | Intel® Developer Zone and let us know the outcome.

           

          Regards;

          CMata

          • 2. Re: Bricked Edison flashing from Ubilinux back to Yocto
            jb22

            No luck Here's the log (log-level=TRACE): [Bash] Edison Flash Tool Lite Fail - Pastebin.com

             

            It seems the device is no longer recognised, maybe because u-boot bombs out too soon?

             

            What is the significance of 'GADGET DRIVER: usb_dnl_dfu', the line which u-boot hangs?

             

            Thanks,

            jb

            • 3. Re: Bricked Edison flashing from Ubilinux back to Yocto
              philtkp

              I was able to recover my Edison using this link. I'm using the arduino Edison board. Intel® Edison Boards — Recovering Intel® Edison if Password is Unknown

              I think it might have something to do with adding the power supply do know but like I said worked for me

              • 4. Re: Bricked Edison flashing from Ubilinux back to Yocto
                jb22

                Thanks philtkp, this gave me some useful debugging info even though it didn't fix it! Here's the log from 'run do_ota': http://pastebin.com/4AQx7bWd

                I had originally tried flashing my own build of yocto onto the Edison before reverting to trying the Intel stock build. From the compile time and the sha1sum in the log above, it seems that the image files on the board which it's reflashing are from my custom build:

                 

                    boot > version

                    U-Boot 2014.04 (Jun 11 2015 - 02:36:24)

                    i586-poky-linux-gcc (GCC) 4.8.2

                    GNU ld (GNU Binutils) 2.24

                 

                The sha1sum of my custom u-boot images differs to the stock build even though the file sizes are identical, so I'm think it's corrupt somehow :

                    ~/edison$ sha1sum stock/*u-boot*

                    55fb1663be1910b91d560791bdf49b4ded910dfb  stock/u-boot-edison.bin

                    4c99840162953e21e8997725e52a6df898fcb3f9  stock/u-boot-edison.img

                 

                    ~/edison$ sha1sum custom/*u-boot*

                    a89c6a907a6628a089cf17059e1808052c2dcd62  custom/u-boot-edison.bin

                    29eee80c59b57b0d11f6bd99f88af0efbe48e41c  custom/u-boot-edison.img

                 

                    ~/edison$ ls -la custom/ | grep u-boot

                    -rwxr-xr-x 1 jb jb    245760 Jun 11 20:28 u-boot-edison.bin

                    -rwxr-xr-x 1 jb jb   6291968 Jun 11 20:28 u-boot-edison.img

                 

                    ~/edison$ ls -la stock/ | grep u-boot

                    -rwxr-xr-x 1 jb jb    245760 Apr 29 04:01 u-boot-edison.bin

                    -rwxr-xr-x 1 jb jb   6291968 Apr 29 04:01 u-boot-edison.img

                 

                It's not actually booting to the stage of being able to access the storage via Ubuntu, so I am unable to put new images on for the ota and both flash tools are not helping either.

                 

                Next stage would be to manually upload a fresh copy of u-boot via the boot prompt over serial some how?

                • 5. Re: Bricked Edison flashing from Ubilinux back to Yocto
                  jb22

                  Urm, so turns out this was a mixture of user error and a dodgy u-boot image! I also read the thing about adding the power supply which I did and assumed that the flashing was over serial (I the a mini-breakout board) so I had stopped plugging in the other USB cable...hence why neither flash tools could see the device!

                   

                  Flashed the stock yocto back onto it and all is good. Now to work out what went wrong with compiling my own image!

                   

                  Thanks for the help