5 Replies Latest reply on Jul 3, 2015 2:38 AM by Nekraus

    Wvdial don't work

    Nekraus

      Hi! I want use a 3g modem Huawei. The modem is recognized

      [  157.139998] usb 1-1: New USB device found, idVendor=12d1, idProduct=1c25

      [  157.140072] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3

      [  157.140097] usb 1-1: Product: HUAWEI Mobile

      [  157.140157] usb 1-1: Manufacturer: Huawei Technologies Co., Ltd.

      [  157.140178] usb 1-1: SerialNumber: FFFFFFFFFFFFFFFF

      [  157.194546] cdc_ether 1-1:2.0 eth0: register 'cdc_ether' at usb-dwc3-host.2-1, CDC Ethernet Device, 00:1e:10:1f:00:00

      [  157.196768] option 1-1:2.2: GSM modem (1-port) converter detected

      [  157.199070] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0

      [  157.199879] option 1-1:2.3: GSM modem (1-port) converter detected

      [  157.201109] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1

      [  157.201792] option 1-1:2.4: GSM modem (1-port) converter detected

      [  157.203074] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2

      [  157.203863] option 1-1:2.5: GSM modem (1-port) converter detected

      [  157.211454] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3

      [  157.329292] systemd-udevd[361]: renamed network interface eth0 to enp0s17u1c2

       

      But when I use wvdial,  I got this error :

      --> WvDial: Internet dialer version 1.61

      --> Initializing modem.

      --> Sending: ATZ

      ATZ

      OK

      --> Sending: ATQ0 V1 E1 S0=0

      ATQ0 V1 E1 S0=0

      OK

      --> Sending: AT+CGDCONT=1,"IP","sl2sfr"

      AT+CGDCONT=1,"IP","sl2sfr"

      OK

      --> Modem initialized.

      wvdial: utils/wvtask.cc:409: static void WvTaskMan::_stackmaster(): Assertion `magic_number == -0x123678' failed.

      Aborted

       

       

      thanks for your help