4 Replies Latest reply on Aug 11, 2015 4:09 PM by Malvineous

    i7-4770K (3.5GHz) won't go above 3.2GHz

    Malvineous

      Hi all,

       

      I'm running Linux, and I have noticed that my i7-4770K CPU never goes above 3.2GHz.

       

      When it is under full load (e.g. compiling in parallel) it stays at 2.992GHz, and when it is idle it creeps up just above 3.1GHz, but never goes any higher.  The Linux cpufreq information tells me that the processor is reporting its maximum speed as 3.2GHz.  Why would this be, when it is marketed as a 3.5GHz processor with the ability to Turbo Boost up to 3.9GHz?

       

      Socket [0] - [physical cores=4, logical cores=8, max online cores ever=4]
        TURBO ENABLED on 4 Cores, Hyper Threading ON
        Max Frequency without considering Turbo 3091.73 MHz (99.73 x [31])
        Max TURBO Multiplier (if Enabled) with 1/2/3/4 Cores is  32x/32x/31x/30x
        Real Current Frequency 2992.01 MHz [99.73 x 30.00] (Max of below)
              Core [core-id]  :Actual Freq (Mult.)      C0%   Halt(C1)%  C3 %   C6 %   C7 %  Temp      VCore
              Core 1 [0]:       2992.01 (30.00x)       100       1       0       0       0    54      0.9540
              Core 2 [1]:       2992.00 (30.00x)       100       1       0       0       0    59      0.9515
              Core 3 [2]:       2992.00 (30.00x)       100       1       0       0       0    57      0.9517
              Core 4 [3]:       2992.00 (30.00x)       100       1       0       0       0    56      0.9540
      
      $ cat /proc/cpuinfo
      model name      : Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
      cpu MHz         : 3000.351
      
      $ cat /sys/bus/cpu/devices/cpu0/cpufreq/cpuinfo_max_freq
      3200000
      

       

      I'm running this in an Intel DH87MC desktop motherboard, and temperatures rarely go over 60 degrees even under full load so I don't think it's a thermal problem.  Does anyone know why the processor is running much slower than its rated speed?

       

      Thanks!

       

      (P.S. Sorry for the ugly post, looks like <pre> doesn't show up in a fixed-width font after you post)

        • 1. Re: i7-4770K (3.5GHz) won't go above 3.2GHz
          hansb_intel

          Hello Malvineous,

           

          Have you made any changes in the BIOS? It seems that the Turbo ratio and the Processor Base Frequency have been lowered. I suggest that you load the BIOS defaults; this should bring any settings back to standard.

          • 2. Re: i7-4770K (3.5GHz) won't go above 3.2GHz
            Malvineous

            Hi, thanks for the reply.  I have found some time to reboot and have a look in the BIOS and it does indeed seem that the multipliers have been lowered - although I can't turn them up again.  It seems to be fixed at 30 for non turbo boost.  I wasn't able to adjust any of the turbo boost options either.

             

            bios1.jpg

             

            I worked out that if I clicked on the "x 0" under the "Cores" heading, although I couldn't change it, if I pressed the arrow buttons a little bit a slider would suddenly appear that let me adjust the value.  I don't know why this doesn't come up when you click on it, that would seem most logical to me, but maybe it's a secret setting and you can only get to it with keyboard navigation.

             

            Anyway, adjusting that changed the settings on the right for some reason:

             

            bios2.jpg

             

            I still wasn't able to adjust the non-turbo ratio (which should be 35 for the 3.5GHz base speed) however booting back into Linux this does at least seem to allow me to get close to 3.9GHz in boost mode.  I tried upping it past 39 up to 45 to see if I could reach at least 3.9GHz but it doesn't seem to make any difference.  It's faster than before, but still only maxes out at about 3.8GHz.

             

            I'm a bit reluctant to reset the settings to defaults since I have customised a lot of things, like making only my external SATA ports hotplug, but do you think this will work?  It is a bit weird all the voltages and multipliers were originally set to zero.

             

            Maybe the bus speed/host clock needs to be increased?  The Ark for the CPU doesn't seem to list a bus speed so I'm not sure whether 100MHz is correct.

             

            Thanks for any ideas.

            • 3. Re: i7-4770K (3.5GHz) won't go above 3.2GHz
              hansb_intel

              Hi Malvineous,

               

              The host clock is ok, 100 mhz is the standard, but I see that most of these options are offset.

              Try setting the “ring” to 38 and see what happens, if this does not help, you would be better off setting default values and then adjusting your personal preferences.

               

              To keep track of your current settings, the BIOS has an option which lets you save changes as personal profiles, you can do this with the button with a silhouette of a person, this way you would not lose any changes you have made and you can always switch back and forth.

              • 4. Re: i7-4770K (3.5GHz) won't go above 3.2GHz
                Malvineous

                Thanks for the suggestion, and sorry for taking so long to try it out, rebooting is a bit of a hassle for me!

                 

                I reset everything to the defaults and then set all my preferences back again, and it worked!  The CPU sat at 35/3.5GHz and went up to 37/3.7GHz, but it didn't reach the full 39/3.9GHz multiplier.  i7z did say the max turbo boost multipliers were 39x/38x/37x/37x for 1/2/3/4 cores, so I guess this is something in the fine print of turbo boost - if you are boosting all four cores then you can't reach the same speeds as you can if you are only using one core.

                 

                I went back into the BIOS and changed the turbo boost multiplier to 45x to see what would happen, and now i7z reports the 1/2/3/4 core maximum multiplier as 45x/45x/45x/45x so this would appear to work (by work I mean upping the max turbo boost multiplier for 4-core use), except when I go run my C++ compiler again I still only reach 37/3.7GHz, so I guess it's not possible to override this multiplier after all, to get the full turbo-boost speed when four cores are active.

                 

                Anyway, looks like the original problem is solved, so thank you very much for your assistance!