1 Reply Latest reply on Jun 7, 2015 9:24 AM by tbonkers

    Galileo gen 1 and Intel Centrino Advanced N6205

    tbonkers

      Hello

       

      I am trying to get my Galileo working with a wireless card. I have downloaded and installed the drivers and it appears that the Galileo detects the PCI card without problems. I was following Sergey's blog and a post on Spider Electron about how to set the WiFi; so far without any success. It is my first encounter with Linux, so I am a little unsure of what I do. Here's what I have so far:

      root@galileo:/# lspci -v | grep -iA 7 network
      01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak]
              Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN
              Flags: bus master, fast devsel, latency 0, IRQ 43
              Memory at 90000000 (64-bit, non-prefetchable) [size=8K]
              Capabilities: [c8] Power Management version 3
              Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
              Capabilities: [e0] Express Endpoint, MSI 00
              Capabilities: [100] Advanced Error Reporting
      root@galileo:/# dmesg | grep iwlwifi
      [    7.930666] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
      [    7.936761] iwlwifi 0000:01:00.0: enabling bus mastering
      [    7.937058] iwlwifi 0000:01:00.0: irq 43 for MSI/MSI-X
      [    8.037240] iwlwifi 0000:01:00.0: loaded firmware version 18.168.6.1
      [    8.840111] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUG disabled
      [    8.846212] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
      [    8.852455] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
      [    8.859211] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled
      [    8.866116] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_P2P enabled
      [    8.871905] iwlwifi 0000:01:00.0: Detected Intel(R) Centrino(R) Advanced-N 62     05 AGN, REV=0xB0
      [    8.963849] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S
      [  143.635616] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S
      [  143.650754] iwlwifi 0000:01:00.0: Radio type=0x1-0x0-0x1
      [  144.086827] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S
      [  144.100436] iwlwifi 0000:01:00.0: Radio type=0x1-0x0-0x1
      
      

       

      And here's my interfaces file:

      #loopback interface
      auto lo
      iface lo inet loopback
      
      #wireless interface
      auto wlp1s0
      iface wlp1s0 inet dhcp
      wpa-driver wext
      wpa-ssid MYNETWORK
      wpa-proto WPA
      wpa-pairwise TKIP
      wpa-group TKIP
      wpa-key-mgmt WPA-PSK
      wpa-psk 0f505b0d514b61ceef62b247e8e7513246cd3155a7dae65adc5dcdecf5de4b32
      

       

      I am using WPA-PSK on my router. Tried with WPA2-PSK without any effect. The wireless interface is named wlp1s0 and does not turn on automatically after reboot. I can turn it off and on with ifconfig. Here's what is happening when I do this:

       

      root@galileo:/# ifconfig wlp1s0 down
      root@galileo:/# ifup wlp1s0
      [ 1400.623123] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S
      [ 1400.639221] iwlwifi 0000:01:00.0: Radio type=0x1-0x0-0x1
      [ 1400.904907] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
      udhcpc (v1.22.1) started
      Sending discover...
      Sending discover...
      Sending discover...
      Sending discover...
      

       

      And nothing more than this. Here's result of manually starting wpa_supplicant:

       

      root@galileo:/# wpa_supplicant -i wlp1s0 -c /etc/wpa_supplicant.conf
      Successfully initialized wpa_supplicant
      wlp1s0: CTRL-EVENT-SCAN-STARTED
      wlp1s0: SME: Try[ 1599.692797] wlp1s0: authenticate with 4c:17:eb:8f:ea:fa
      ing to authenticate with 4c:17:eb:8f:ea:fa (SSID='SKYFEAF9' freq=2412 MHz)
      [ 1599.706661] wlp1s0: send auth to 4c:17:eb:8f:ea:fa (try 1/3)
      [ 1599.715456] wlp1s0: authenticated
      wlp1s0: Trying to associate with[ 1599.721125] wlp1s0: associate with 4c:17:eb:8f:ea:fa (try 1/3)
       4c:17:eb:8f:ea:fa (SSID='SKYFEAF9' freq=2412 MHz)
      [ 1599.733213] wlp1s0: RX AssocResp from 4c:17:eb:8f:ea:fa (capab=0x411 status=0 aid=4)
      [ 1599.748966] wlp1s0: associated
      [ 1599.752361] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
      wlp1s0: Associated with 4c:17:eb:8f:ea:fa
      wlp1s0: WPA: Key negotiation completed with 4c:17:eb:8f:ea:fa [PTK=CCMP GTK=TKIP]
      wlp1s0: CTRL-EVENT-CONNECTED - Connection to 4c:17:eb:8f:ea:fa completed [id=0 id_str=]
      

      And stops there without actually connecting.

       

      I would appreciate any help. I have lost one full day in trying to get this working so I feel it's time to ask. Thanks a lot!