5 Replies Latest reply on Jun 16, 2015 12:21 AM by palekid

    Servo.H error 1.6.0 Galileo

    palekid

      Hi all,

       

      I am new to the Galileo but have been working with arduino for around a year.

       

      I am trying to make a robot operate just by changing my UNO board to the Galileo,after doing this I can look at some new features with all the extra ports on the Galileo.

       

      I am having major trouble with the libraries. I looked at some posts and it seems servo used to have to be changed to PWM but now it doesn't. Anyway I guess my problem is I can't get the libraries to include. (AFmotor.h, Servo.h and NewPing.h)

       

      Anyway here is the error:

       

           Arduino: 1.6.0 (Windows 8), Board: "Intel® Galileo Gen2"

       

           APC_17_RollyMkII_v3.ino:5:21: fatal error: AFMotor.h: No such file or directory

       

           compilation terminated.

       

           Error compiling.

       

             This report would have more information with

             "Show verbose output during compilation"

             enabled in File > Preferences.

       

       

       

      Here is the robot website: Arduino Projects: The Rolly Mk. II robot - APC   Code here: http://www.futurecomps.com.au/apc-tl/arduino/apc_17_rolly_mkII.zip

       

      What I noob, tried:

       

      1.I have tried moving the Servo.H file around the libraries... but no luck

      2.I also tried Galileo Servo Library Fixes  tried to download and use these servo.h files

       

      Help please, I can attach the verbose error if you need?

       

      first post hi, palekid.