3 Replies Latest reply on Jun 13, 2015 2:48 PM by FZ101

    D34010WYKH BIOS missing?

    FZ101

      The following is supposed to be the BIOS update for the D34010WYKH model: https://downloadcenter.intel.com/download/24881/BIOS-Update-WYLPT10H-86A-

      But at the bottom of the page it says that the download is valid for:

       

      There is no Intel® NUC Kit D34010WYKH - the WYK version is the slimmer model. Am I on the right page and it's just a mistake on the site or...? It seems logical that the WYk and WYKH would have the same BIOS updates but I want to make sure.

        • 1. Re: D34010WYKH BIOS missing?
          FZ101

          I should also mention that the reason to why I am trying to update the BIOS is because my Logictech wireless receiver does not work when I plug it to the USB-port. I have to plug in a wired keyboard to get to BIOS and THEN the receiver works all of a sudden (while the wired keyboard is plugged in). When I unplug the wired keyboard then the receiver stops working again. I was hoping that a BIOS update might solve this (although the release notes doesn't indicate such problems/fixes).

           

          So for anyone addressing this thread, please answer both the OP and this one.

           

          The current installed BIOS is 0035.

          • 2. Re: D34010WYKH BIOS missing?
            hansb_intel

            Hi FZ101,

             

            Regarding the BIOS update for your NUC model, the D34010WYKH and the D34010WYK use the same motherboard which is the D34010WYB; the “H” is just to represent the thicker chassis.

             

            Regarding the wireless receiver issue, a few months back I found that I had this same issue with a Logitech* bluetooth mouse, it would not work upon reboot but once I connected a wired keyboard to the NUC It would start to work again. I ran some more tests with a couple of other brands and I did not have this issue, I tested all the USB ports and they all worked. This kind of pointed to some type of compatibility issue but I could never really isolate the problem since the Logitech mouse stopped displaying this behavior by itself and is working fine now.

             

            So I would suggest you try the following:

             

            Update the BIOS to the latest version.

            Let me know if you have tested this with both the USB 2.0 and the 3.0 ports.

            Make sure to have the latest USB 3.0 drivers if you are using Windows* 7.

            You can try putting the receiver on a USB extension cable; this is in case there is some kind of radio interference coming from another device in the NUC like a wifi card.

            Lastly, try using some other brand if possible, this is just to test if you have the same behavior.

            • 3. Re: D34010WYKH BIOS missing?
              FZ101

              Thanks. I updated the BIOS but it didn't make a difference.

               

              "this is in case there is some kind of radio interference coming from another device in the NUC like a wifi card".
              I tried using a USB-extension and it worked. You are however coming to the wrong conclusion; there is no interference from nearby devices, the interference comes from the NUC itself. I googled the issue further after my post, this is apparently a known issue that Intel had for quite some time.

               

              I am not pleased with this so called solution with using an USB extension. This mean that Intel did a lousy job making this box and I had to solve it on my own with an unpractical solution that cost me even more money.