3 Replies Latest reply on Jun 4, 2015 7:02 AM by stephencwelch

    flashall on OSX

    stephencwelch

      Hello,

       

           I'm running into some dfu issues when running flashall on OSX. Things seem to fall apart around:

       

           dfu-util: Device has DFU interface, but has no DFU functional descriptor

       

      sudo ./flashall.sh

      Password:

      Using U-Boot target: edison-blankcdc

      Now waiting for dfu device 8087:0a99

      Please plug and reboot the board

      dfu-util: Device has DFU interface, but has no DFU functional descriptor

      Flashing IFWI

      dfu-util: Device has DFU interface, but has no DFU functional descriptor

      Download        [=========================] 100%      4194304 bytes

      Flashing U-Boot

      Download        [=========================] 100%       245760 bytes

      Flashing U-Boot Environment

      Download        [=========================] 100%        65536 bytes

      Flashing U-Boot Environment Backup

      Download        [=========================] 100%        65536 bytes

      Rebooting to apply partition changes

      Now waiting for dfu device 8087:0a99

      dfu-util: Device has DFU interface, but has no DFU functional descriptor

      Flashing boot partition (kernel)

      Flashing rootfs, (it can take up to 5 minutes... Please be patient)

      Rebooting

      U-boot & Kernel System Flash Success...

      Your board needs to reboot to complete the flashing procedure, please do not unplug it for 2 minutes.