1 2 Previous Next 16 Replies Latest reply on Sep 18, 2015 5:10 AM by navneet77

    Wireless AC7260 - No ac/n only a/b/g

    Skubacb

      When I first got the Dell Laptop XPS 15 Touch (windows 8.1 - 64) I was able to log onto my AC/N network. 

      It stopped working on ac/n.  I updated to the latest drivers here and it will still only log onto the a/b/g side of the router.

      This is not a router problem since I can log onto AC/N with other computers. 

      In the advanced configuration for the Intel(R) Dual Band Wireless-AC 7260 under wireless mode it does not list the ac/n.  It only shows a/b/g

       

      What is going on.  How do I re-enable ac/n? Help is much appreciated.

        • 1. Re: Wireless AC7260 - No ac/n only a/b/g
          RedBrick58

          INTEL: WE ARE ALL STUCK IN G MODE OUT HERE! PLZ FIX!!

           

          I've got the exact same issue under Windows 8.1 on Gigabyte P35V2.

          The model of laptop shouldnt matter though.

           

          Its the driver itself.

          • 2. Re: Wireless AC7260 - No ac/n only a/b/g
            jonathan_intel

            Hello Skubacb,

             

            The Wireless N and ac capabilities are not set from the "Wireless mode" in the advanced properties, it is normal to see only 802.11a/b/g in this section. Try using the configuration from the advisory: What are the Recommended Settings for 802.11n Connectivity?

             

            Also, check if your PC is connecting to the correct SSID, and confirm that the wireless access point is properly configured for 802.11ac connections.

             

            For further assistance, provide the following information:

            Were there any changes made in the system recently?

            Do you use the driver provided by the PC manufacturer, or is it the one from Intel?

            Wireless driver (as shown in device manager), Intel® PROSet/Wireless software version, router model and firmware version.

            • 3. Re: Wireless AC7260 - No ac/n only a/b/g
              RedBrick58

              This is pointed to in the registry at HKEY_LOCAL_MACHINE\SOFTWARE\intel\WirelessAssistant\config:

              C:\Program Files\Intel\WiFi\bin\WiFiProviderConfigVISTA.xml

              from there you get pointed to this xml file;

              C:\Program Files\Intel\WiFi\bin\WiFiProvider.xslt

              Notice that N is not even listed as an adapter feature...

               

              <xsl:template match="AdapterFeatures"> <h2>Adapter Features</h2> <ul> <li> <b>Antenna Diversity: </b> <xsl:value-of select="AntennaDiversity"/> </li> <li> <b>Beacon Interval: </b> <xsl:value-of select="BeaconInterval"/> </li> <li> <b>Frag Threshold: </b> <xsl:value-of select="FragThreshold"/> </li> <li> <b>RTS Threshold: </b> <xsl:value-of select="RTSThreshold"/> </li>     <li> <b>Sweep Table: </b> <xsl:value-of select="SweepTable"/> </li> <li> <b>AP Table: </b> <xsl:value-of select="APTable"/> </li> <li> <b>Peer Table: </b> <xsl:value-of select="PeerTable"/> </li> <li> <b>Radio State: </b> <xsl:value-of select="RadioState"/> </li> <li> <b>Preamble: </b> <xsl:value-of select="Preamble"/> </li> <li> <b>QOS: </b> <xsl:value-of select="QOS"/> </li> <li> <b>Auto Exclude: </b> <xsl:value-of select="AutoExclude"/> </li> <li> <b>EoU: </b> <xsl:value-of select="EoU"/> </li> <li> <b>CCXv1: </b> <xsl:value-of select="CCXv1"/> </li> <li> <b>CCXv2: </b> <xsl:value-of select="CCXv2"/> </li> <li> <b>CCXv3: </b> <xsl:value-of select="CCXv3"/> </li> <li> <b>CCXv4: </b> <xsl:value-of select="CCXv4"/> </li> <li> <b>Band802.11d: </b> <xsl:value-of select="Band802.11d"/> </li> <li> <b>Band802.11WME: </b> <xsl:value-of select="Band802.11WME"/> </li> <li> <b>Band802.11h: </b> <xsl:value-of select="Band802.11h"/> </li> <li> <b>Band802.11e: </b> <xsl:value-of select="Band802.11e"/> </li> <li> <b>Band802.11hRadarDetection:</b><xsl:value-of select="Band802.11hRadarDetection"/> </li> <li> <b>Band802.11TGk: </b> <xsl:value-of select="Band802.11TGk"/> </li> <li> <b>Band802.11TGj: </b> <xsl:value-of select="Band802.11TGj"/> </li> <li> <b>IBSSControl: </b> <xsl:value-of select="IBSSControl"/> </li> <li> <b>PowerMode: </b> <xsl:value-of select="PowerMode"/> </li> <li> <b>AutoPSP: </b> <xsl:value-of select="AutoPSP"/> </li> <li> <b>PowerSource: </b> <xsl:value-of select="PowerSource"/> </li> <li> <b>BSSTxPowerControl: </b> <xsl:value-of select="BSSTxPowerControl"/> </li> <li> <b>IBSSTxPowerControl: </b> <xsl:value-of select="IBSSTxPowerControl"/> </li> <li> <b>WEP: </b> <xsl:value-of select="WEP"/> </li> <li> <b>Band802.1X: </b> <xsl:value-of select="Band802.1X"/> </li> <li> <b>LEAP: </b> <xsl:value-of select="LEAP"/>      </li> <li> <b>TKIP: </b> <xsl:value-of select="TKIP"/> </li> <li> <b>AES: </b> <xsl:value-of select="AES"/> </li> <li> <b>HWRadioSwitch: </b> <xsl:value-of select="HWRadioSwitch"/> </li> <li> <b>HWWOWL: </b> <xsl:value-of select="HWWOWL"/> </li> <li> <b>Band802.11a: </b> <xsl:value-of select="Band802.11a"/> </li> <li> <b>Band802.11b: </b> <xsl:value-of select="Band802.11b"/> </li> <li> <b>Band802.11g: </b> <xsl:value-of select="Band802.11g"/> </li> </ul> </xsl:template>

              • 4. Re: Wireless AC7260 - No ac/n only a/b/g
                RedBrick58
                PropertyValue
                802.11n channel width for band 2.4Auto (not in 20 MHz only)
                802.11n channel width for band 5.2Auto (not in 20 MHz only)
                802.11n modeEnabled
                Fat channel intolerantDisabled
                Roaming aggressivenessMedium (or less)
                Throughput enhancementDisabled
                Transmit powerHighest
                Wireless mode802.11a/b/g
                HT modeVHT mode

                 

                Where the chart shows 802.11n mode --- that is missing!

                All of the other Properties are there...

                • 5. Re: Wireless AC7260 - No ac/n only a/b/g
                  theveterans

                  For 7260 series, 802.11n mode is replaced by "HT Mode". VHT mode is called Very High Throughput mode which is 802.11ac mode while HT mode is called High Throughput mode which is 802.11n mode in layman's terms.

                   

                  Check your WiFi connection status and your Windows Task Manager WiFi status to see if the mode is 802.11ac or if the speed is above 300 Mbps. If they are, you're definitely in 802.11ac connection. If not, report the speed here so I can see if this speed only exists in 802.11ac mode or not. For example, 87 Mbps link speed only exists in 802.11ac.

                   

                  For reference speeds,

                  go here: IEEE 802.11ac - Wikipedia, the free encyclopedia

                   

                  Essentially, Any speeds located in the 80 MHz channel column and 256-QAM (MCS 8-9) that are not duplicated anywhere in the 20-40 MHz channel column and MCS 0-7(rows) are only availble in 802.11ac mode.

                  • 6. Re: Wireless AC7260 - No ac/n only a/b/g
                    RedBrick58

                    Thank you. I will adjust and see if I can get anything better than 30mb/sec on my 115ms/sec wifi setup...

                    • 7. Re: Wireless AC7260 - No ac/n only a/b/g
                      RedBrick58

                      Well, as it turns out, that was already set to that value.

                      I'm still a little baffled...

                      This is the second windows machine that I have encountered this issue on.

                      My MacBook Pro has no trouble on the same wireless setup of hitting 115mb/sec using the Broadcom BCM43xx 1.0 (7.15.166.24.3).

                      I'm not trying to be a snob, I am just showing that the wireless setup here is fully capable of delivering those speeds and there doesn't seem to be a logical reason for the windows machines with an ac wireless adapter, to not do the same.

                       

                      On both windows machines, the most I can get is about 24mb/sec. ONCE -- any only ONCE -- after I uninstalled the drivers and forced them to reinstall -- did I get 105mb/sec one of these machines. That time, it got up that far, but it was short-lived: After a few seconds it started to drop and I wound up with 80mb/sec. A second attempt and I was right back to the old 22.5mb/sec.


                      Numerous sites were checked against for verifying the problem.

                      Google search shows that many are having the same issue. What gives?


                      Task Manager shows that the card is in G Mode...

                      • 8. Re: Wireless AC7260 - No ac/n only a/b/g
                        RedBrick58

                        I am wondering then, is the chart referenced above (from the Intel website referenced earlier) incorrect to show both the 802.11n mode enable and the HT Mode set to VHT Mode?

                        • 9. Re: Wireless AC7260 - No ac/n only a/b/g
                          RedBrick58

                          UPDATE:

                          Ok. I thought I MIGHT have a fix, but it did not work...

                          I uninstalled the driver and told it to delete the driver files

                          Then I went to http://www.intel.com/p/en_US/support/detect

                          Installed and ran the Intel Driver Update Utility in Auto Detect mode...

                          Downloaded the ProSet Wireless Software

                          Rebooted to clear registry and memory

                          Installed the new drivers from the Downloads/Intel Components directory the tool created

                          It completed without errors

                          Rebooted and tried to connect.

                          Results with latest driver:

                          Cannot connect on 5Ghz at all, 2Ghz is so unstable that I had to write this on my Mac.

                           

                          The attachments show my current state of affairs.

                          The driver version is 17.x.x.x.x

                          • 10. Re: Wireless AC7260 - No ac/n only a/b/g
                            RedBrick58

                            One more small piece of information for those whom this will be enough....

                             

                            Under the Interface Properties, I uninstalled the QoS driver, under the Advanced driver properties I disabled the WMM property.

                            Also, you should check your routers wifi interface to ensure that all WMM restrictions are turned off -- on BOTH 2 and 5Ghz.

                            • 11. Re: Wireless AC7260 - No ac/n only a/b/g
                              Skubacb

                              This is not an issue with the network, IPs, router settings etc.   In the advanced configuration is is set to Auto for N.  There is NO issue here with settings (at least any normal settings). Other devices connect to the AC network without problems.  Plus it initially did connect to AC/N

                              Nothing here: What are the Recommended Settings for 802.11n Connectivity?  that I have not tried.


                              BTW thanks to the people trying to go deeper on this.

                               

                              The device just refuses to connect to AC/N networks.  What is wrong here is that previously when I first bought the laptop it did connect.  I can only figure that at some time some Windows or Intel update fixed the AC/N for us so that it does not work.

                               

                              Tried the uninstall plus hand cleaning of the registry.  If it is in there I cannot find it.

                              • 12. Re: Wireless AC7260 - No ac/n only a/b/g
                                RedBrick58

                                Skubacb

                                I agree 100%.

                                My statement above was for those looking for a clue where the above hints were all that were necessary to get them going.

                                 

                                The issue we are discussing here is not related to any of that.

                                I also have "run the gauntlet" on this issue to no avail.

                                This issue is clearly a driver issue.

                                 

                                I am going to try to find and install some legacy drivers (v14 or so) and see how that goes...

                                I'll let you know.

                                • 13. Re: Wireless AC7260 - No ac/n only a/b/g
                                  RedBrick58

                                  Ok. I've wasted enough time on this.

                                  I have tried absolutely every conceivable workaround I can think of to resolve this issue and I am left with only one conclusion:

                                  The drivers are buggy as hell and there isn't a danged thing the consumer can do about it.

                                   

                                  What gets me is that it USED to work fine. Now, I cant even connect on 5Ghz if VHT is set!

                                  And, I get my best speeds available (a whole wopping 31mb/sec on 2Ghz with HT mode disabled!

                                   

                                  Anyway, I sure hope that the driver developers can figure it all out and get a good driver out there...

                                  In the meantime, I have to ask: What the hell good is a laptop without WiFi?

                                  This issue is leaving a LOT of people in the lurch...

                                  • 14. Re: Wireless AC7260 - No ac/n only a/b/g
                                    RedBrick58

                                    Looks like we have another thread along similar lines; one which provides additional "evidence" that HT Mode appears to be hosing up the process...

                                    Activating VHT disables my AC7260 Internet

                                     

                                    I have invited the person that started that thread to come over here, read through what has been written and then chime in...

                                    1 2 Previous Next