6 Replies Latest reply on Jun 26, 2015 10:43 AM by EmilG

    Updating MRAA version in Intel Eclipse IDE

    Nicobari

      Hi,

      So I ran into one more problem. I was trying to use Uart class in Intel Eclipse and the only methods in that class are constructor, destructor and getDevicePath. I am assuming I have old version of mraa because the mraa: Uart Class Reference for mraa 0.7.0 has everything in the Uart class. So I went ahead and downloaded mraa 0.7.0 from mraa-update/ for windows and extracted it in my iotdk-ide-win folder and restarted my Eclipse. The funny thing is I am still not getting all the new members in the Uart class, what gives? Am I skipping any intermediate steps to update mraa library on my windows side? Thanks in advance.

       

      Regards,

      TM

       

      Message was edited by: Nicobari Jarawa When I check I have updated uart.h and usart.hpp files but still Eclipse shows error

       

      Message was edited by: Nicobari Jarawa: Edit2 So I rebuild the system files and now I can compile file easily on Eclipse but when I run the code on Intel Edison it gives me the error undefined symbol: mraa_uart_set_baudrate. It must be that my mraa version on Intel Edison is 0.6.2.13. How can I update the mraa version to 0.7.0. I tried this link https://github.com/intel-iot-devkit/mraa but it will only update upto 0.6.13