2 Replies Latest reply on Jun 1, 2015 1:24 AM by llepage

    NUC DN2820FYKH Access to BIOS not possible via F2 key

    llepage

      Hello,

       

      Just have bought a NUC DN2820FYKH.

      I need to access to the BIOS configuration...if not...impossible to install most of the OS because of ACPI parameters.

       

      My problem is that I can't access to the BIOS by typing F2 at the boot screen...It doesn't work!

      I have already read some threads about this problem but i have not saw any solution.

       

      I have tried to upgrade to the latest BIOS FYBYT10H.86A (version 0050...I was first in 0034).

      Unfortunately...the problem is the same with this BIOS.

       

      I have tried 3 differents HDMI cables and 3 differents TV.

      It seems BIOS send 1024x768 resolution to the screen/TV but I can't believe that my 3 TV are not able to print this resolution.

       

      What can I do? Do you have any idea please?

      Best Regards

      Laurent

        • 1. Re: NUC DN2820FYKH Access to BIOS not possible via F2 key
          dougho

          Can you clarify whether your problem is that you do not get the chance to press F2 (so you get some error message about boot device if you do not have an OS bootable), or is the problem that you get the chance to press F2 but then the screen changes to some unusable screen (blank, or unreadable)?  If the former, I think that NUC has the "Power button menu" which should give you a chance to enter the BIOS settings.  The sequence is very specific, it is something like start from power-off, then hold down power button for a very specific amount of time I think around 3-4 seconds (not longer and not shorter), then you should get the menu.  If the problem is the later, the problem seems to be that the NUC is attempting to read the capabilities of the TV and then display 1024x768 centered within the screen.  Trouble reports often seem to be if you are running the HDMI through some AVR (receiver) or to TVs whose specifications say that HDMI input is not intended for computer (sometimes a certain HDMI input such as #1 is better from computer than some higher numbered input).  Finally, when I got my NUC (long ago) it was delivered with a BIOS that did not work with my computer monitor (but it did work with an HDTV) and it was delivered with a BIOS which did not work with any Microsoft-brand keyboard.  I had to find/borrow a different brand keyboard (I think it may have been a PS/2 keyboard with an adapter to USB) then I was able to use the keyboard (such as F2 or F7) and update the BIOS - after that the Microsoft-brand keyboards worked fine.

          • 2. Re: NUC DN2820FYKH Access to BIOS not possible via F2 key
            llepage

            Thank you very much Dougho for your complete answer.

            I was in the second situation : Black Screen after F2.

             

            There was a test that I didn't done few days ago...

            After the upgrade of the BIOS, I have tried to reconnect the NUC box on my third TV and it was OK!

            The BIOS were available. I have understood that the BIOS was always available but it was a problem of screen printing/HDMI synch.

             

            With BIOS version 50, I can considere now all is OK and I have well installed Windows 8.1

            Thank you for your help.

            Laurent