2 Replies Latest reply on May 27, 2015 6:50 PM by scottjl

    Enable USB after "disabled" in BIOS

    Claw

      STCK1A32WFCR ( FC0018.BIO )

       

      I'm currently trying to get the stick booting Ubuntu (15.04) headless, without a screen connected to the HDMI port, but without any luck.

       

      As a desperate measure i tried to disable USB in the BIOS settings. But that seems to have been a fatal misstake... now I don't have any input device available, even PRE-boot. In other words, I cannot get into the BIOS setup anymore. I tried to remove the CMOS battery, and I get "CMOS checksum failed" but the USB(-keyboard) is still not available... Any idéas how to resolve this?

       

      The operating system is booting, but since i used a USB-to-ethernet adapter i currently have no way to connect to the linux console via ssh either...

       

      Is it possible to get a serial console somehow? I can see a /dev/ttyS0 device when booting linux, but can't find any connectors or points to connect a serial cable.

        • 1. Re: Enable USB after "disabled" in BIOS
          Claw

          Was a bit too quick here, found the solution for this. Using the power-button BIOS upgrade procedure brought the USB connection back to life.

           

               Intel® Compute Stick Family — Power Button Menu BIOS Update Instructions

          1. Press and hold the power button down for 3 seconds. Release it before the 4 second shutdown override.

           

           

          On the other hand, has anyone managed to get the stick booting headless in "Ubuntu mode" ? It seems that it gets stuck somewhere, but i cannot determine where in the boot process. And if I reconnect the display after power-on, there is NO picture at all... And the operating-system does not boot, in example there is no connectivity through the USB-to-ethernet adapter.

           

          I have only tried Ubuntu 15.04 with numerous different grub options, since the 14.04 Installer does'nt seem to recognize the mmcblk storage device out of the box.

          • 2. Re: Enable USB after "disabled" in BIOS
            scottjl

            15.04 isn't supported by the device, only 14.04 LTS 64 bit. I can say that version boots and runs just fine for me off a microSD card. Didn't try it headless though.