1 Reply Latest reply on May 26, 2015 5:42 PM by JPMontero_Intel

    Qt 5.5 cross compilation for Edison

    avrik

      Hi all!

      I builded toolchain following this instruction http://akizukidenshi.com/download/ds/intel/edison-bsp_ug_331188-001.pdf (section 2.1).

      Then i extracted it and successfully configured Qt with command:

       

      ./configure -opensource -confirm-license -xplatform i586-poky-linux-g++ -extprefix /opt/poky/qt-5.5 -sysroot /home/valentin/Desktop/Projects/edison-src/build/tmp/sysroots/edison -c++11 -no-gui -no-widgets -openssl -no-accessibility -no-iconv -no-icu -nomake examples -qt-xcb -skip location -skip graphicaleffects -skip multimedia -skip quick1 -skip quickcontrols -skip script -skip sensors -skip webkit -skip webkit-examples -no-sse2 -no-sse3 -no-ssse3 -no-sse4.1 -no-sse4.2 -no-avx -no-avx2 -no-xcb -v


      But then I get this error when trying to make:

      Ubuntu Pastebin

       

      I tried different sysroots (from toolchain and from edison-src folder after building edison image). Also tried different ./configure commands.

      As I understand problem in BlueZ compilation.

      How can I fix it?

      I already asked about this in Qt forum, but didn't get answer yet.

       

      Additional info:

      Host system: Ubuntu 15.04

      Target system: Yocto 1.6.1

        • 1. Re: Qt 5.5 cross compilation for Edison
          JPMontero_Intel

          Hi avrik,

           

          I suggest you to create a recipe for Qt 5.5 instead of trying of trying to build it with a SDK. With a recipe you can add it to the build and it will be populated into the SDK as well. Also it will use the resources and tools of the PC for the build instead of using the image you just build. In case you decide to give it a try, here is a guide on writing a new recipe. I hope you find this helpful.

           

          Regards,
          JPMontero_Intel