2 Replies Latest reply on Oct 20, 2009 1:36 PM by TerminusAvid

    Wipe and 7

    jmt54

      I've got 3 X-25 M SSD's (1x80 and 2x160's) on a Classified mb. When I first set up Vista I didn't enable AHCI and when I noticed that, tried to reinstall with it enabled and ran into all kinds of problems and finally got it set up again without it. I want to set up a clean install of 7 when it comes out and I would like AHCI enabled. I'm going to try wiping my SSD's with HDDErase 3.3, clearing cmos, updating the firmware on my drives, flashing the bios and doing a clean install. I feel like I might have missed something, possibly important, so I thought I would throw it out there. Did I miss something? Thanks.

        • 1. Re: Wipe and 7
          Ytterbium

          I've setup vista and 7 with AHCI on my asus boards without issues.  I know that it's tough to switch HDD controlers post install but normally installing should go smoothly.

           

          Check on the eVGA forums to see if anyone else had issues?

          • 2. Re: Wipe and 7
            TerminusAvid

            Like you jmt54 when I installed my first Intel SSD (X25-M 80GB G2) I used the default "Enhanced IDE" settings. Soon after installing the drive I learned about the benefits of enabling AHCI in BIOS, it allows NCQ to work along with a few other things. Well after many hours of research I found a very simple and quick way to enable AHCI even after installing Windows (in my case I have Windows 7 64-Bit). Basically the reason you can't just enabled AHCI in BIOS after installing windows is because there is no AHCI driver up and running to handle it (at least that is my simply understanding of what is happening). So if you try to do it you can run into many issues, it can sometimes even corrupt your OS.

             

            From the research I did there are many different ways to enable AHCI after windows is installed and I tried many of them with no luck. Thankfully I came across a simply method that has worked multiple times for me and my next-door neighbor (I've got an SSD and he has a mechanical drive). Below is the method I used to get it working. By the way after enabling AHCI you can go into "Device Manager", go to the properties of your SSD drive, and then go to the "Policies" tab. Under that tab you should now have an extra setting that you can enable (its essentially NCQ but they call it something else which I can't remember). Good luck guys and let me know if you have any questions regarding the process.

             

          • 1. Exit all Windows-based programs.
          • 2. Click Start, type regedit in the Start Search box, and then press ENTER.
          • 3. If you receive the User Account Control dialog box, click Continue.
          • 4. Locate and then click the following registry subkey:

                   HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Msahci

          • 5. In the right pane, right-click Start in the Name column, and then click Modify.
          • 6. In the Value data box, type 0, and then click OK.
          • 7. On the File menu, click Exit.
          • 8. Now just go into your BIOS and enable "AHCI" and reboot back into Windows.