10 Replies Latest reply on Oct 15, 2009 8:15 AM by SoulReaperZA

    INTEL DP45SG Bios Problem

    SoulReaperZA

      Good day all!

       

      I've received my new board this week and installed everything, after I had some boot problems (getting into Bios). Eventually installed Vista64Sp1, and all the drivers. The current bios date is SGP4510H.86A.0088.2008.0829.1839. All the voltages and Ram values are perfect. Successfully setup Raid0 config.

       

      So far so good...

       

      So when I turn off my Pc and back on, it won't boot, maybe after a few resets. It hangs on post with message 'BA', I guess thats BootAgent?(It runs through a few 'codes' and it stops at this one)

      So I downloaded latest Bios update (express exe mode), and when a ran it, it restarted the PC and the mobo is dead (just black screen, no beeps). Only after removing the cmos batery will the post screen show up. When Windows starts up (eventually), it says the bios was successfull, but it did nothing. Same old Bios. So I tried the recovery method described on the support page, via USB device. But it doesn't work. I tried it with both 'bios config' jumper settings, and without it, as the instuctions said. With the jumper removed, it gives the same black screen, and have to remove battery again to fix it.

      When I do get to Windows, the PC is rock solid, fast, and I've tried a few games. Works Fine!! No crashes. Full settings. I also installed the deskop controll centre, and it works, despite some people saying theirs don't work.

       

      Are there any otherways of Flashing the bios?(appart from the ones listed on the support pages, coz the don't work at all). The boot issue is killing me.

       

      Specs: IntelDP45SG, Intel C2Q9550, Corsair XMS3 DDR3-1333 4Gb (2x2gb), ATI HD4890 1Gb, Gigabyte Odin585w, 2x500Gb(raid0) Seagate.

      Current Bios: SGP4510H.86A.0088.2008.0829.1839.

       

      p.s: english is my 3rd language, appologies for errors.

        • 1. Re: INTEL DP45SG Bios Problem
          Span1shUk

          Hi SoulReaperZA

           

          You have an quite old BIOS version. On the newer versions have fixed a number of RAID issues. And for that I strongly advice you to upgrade BIOS.

           

          Find below a link were you will find the latest version.

           

          http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2932&DwnldID=18047&lang=eng

           

          Let me know if you fix it

           

          Regards

           

          Span1shUk

          • 2. Re: INTEL DP45SG Bios Problem
            SoulReaperZA

            The moment I saw the old date I knew I needed to flash it.

            But the thing is, I can't. Or it won't. I tried the windows method, and the recovery method.

             

            Still need to try the method of booting from a cd.

             

            And I read somewhere that you can press F7, but it does nothing.

             

            I've used many Intel boards in the past, but I never had any issues!!

             

            Thx..

             

            ps. raid is working fine at the moment..

            • 3. Re: INTEL DP45SG Bios Problem
              Aryan2411

              Hello All,

               

              Have you tried the ISO Method?

              http://communities.intel.com/message/15078#15078

               

              Download the ISO file Click Here

               

              How to do ISO Method Click Here

               

              Thank you Spanish1Uk for helping. We have a nice team now.

               

              All the best,

               

              Regards,

              Aryan.

              • 4. Re: INTEL DP45SG Bios Problem
                SoulReaperZA

                Hey guys..

                 

                Guess what? I just tried the exe method again, and strangely it worked fine!! Did nothing special, same as before!!

                 

                The current bios: SGP4510H.86A.0121.2009.0828.1117. (used cpu-z to verify)

                 

                BUT

                 

                The boot problem still persists...

                 

                Let me completely explain: The PC turned off, I press the on button. Then after after a few seconds the blue Intel Bios screen shows up. Then it starts to run through a few codes on the bottom right. At the code 'BA', the system hangs. Now only after I press reset will it continue with the rest of the codes, show my raid config, pops back to blue screen for 3sec, and then continue to boot windows. This happens everytime I need to power up...Also when the system perform any kind of restart (except for reset button), it actually turns off for 2 sec and power up again, then I need to press reset again... I'm so fed up. This totaly screws with my comford zone...

                 

                Any possible causes?? Fix?

                 

                Thx guys!

                • 5. Re: INTEL DP45SG Bios Problem
                  SoulReaperZA

                  The other thing that bugs me is the fact that my moms "classic series' board has more bios options than my current 'extreme series'.

                   

                  But other than all that, the system is very stable, it's been a long time since I've seen a Pc this fast.

                   

                  :-)

                  • 6. Re: INTEL DP45SG Bios Problem
                    Span1shUk

                    Hi SoulReaperZA

                     

                    When you created the RAID the very first time... what RAID drivers you used? From the floopy drive that come with the motherboard? Or you dowload the drivers from Intel Web site?

                     

                    Find below the latest RAID drivers.

                     

                    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2932&DwnldID=15251&lang=eng

                     

                    Is problably best if you create the RAID again-as you have a back up and start from 0.

                     

                    U have a nice system in there!! On a RAID 0 heheeh are you a gamer?

                     

                    Regards

                     

                    Span1shUk

                    • 7. Re: INTEL DP45SG Bios Problem
                      Crewmember

                      I have the same Motherboard and usually get that mesage when hy external hard drive is connected while booting.

                      When i disconnect the Hard drive it works.

                       

                      Also i can't update my bios (same problem you had) using express

                      • 8. Re: INTEL DP45SG Bios Problem
                        SoulReaperZA

                        The Raid is not the problem. I never used any raid drivers. When you set the Sata ports in the bios to raid, it autoruns a Raid tool to config. And since I installed Vista, it natively supports the raid driver. (I actually downloaded the drivers aswell beforehand just incase) .

                         

                        But i found the problem with the boot just now!! Check below.

                         

                        As for gaming, I used to be one about 4years ago. Had a Intel board, P4 2.8GHz 800FSB, 1GB DDR-400 Dual, and a Geforce FX5900, and 80gb..But I gave it to my mon (It retired well and is still as awesome as ever. But it uses onbaord GFX now. That pc is stable as hell. Nothing can crash it.)

                         

                        lol

                         

                        Thx

                        • 9. Re: INTEL DP45SG Bios Problem
                          SoulReaperZA

                          Hey ! Thx for the reply, as it is the fix!!

                           

                          After I tried every possible boot config just now on the boot menu (now its set to disable all except boot from HD), I almost gave up when it struck me that my older amd system had an issue that when I had a external drive attached, windows loaded long after a black screen period of about 2min.

                           

                          So I unplugged my Seagate Free Agent 500gb, (clustersize 512bytes) and Bam!!! System rebooted in less than 30sec to desktop, and I'm replying now!

                           

                          I guess the drive is formatted in such a way to try to be a boot device or something eventhough we disable it. I'll play around with formatting it sometime later, to see what causes it to brick the system.

                           

                           

                           

                          But atleast we know now!!

                           

                          Thx for your reply!!

                          • 10. Re: INTEL DP45SG Bios Problem
                            SoulReaperZA

                            When a user running on Intel DP45SG gets a system hang on power on, Bios code 'BA', it is possibly the attached external drive that causes hang.

                             

                            Unplug it to fix, wait till OS boots, plug it back in.

                             

                            Every possible boot menu config tried, nothing will fix it. Except for manual in/out.