1 2 Previous Next 22 Replies Latest reply on Nov 25, 2009 9:54 AM by rehan

    D945GSEJT hangs after resuming from S3 sleep


      When the OS is set to enter standby (S3), the power light begins blinking. Usually when the board detects a resume signal (ie. power button press, keyboard activity, or ring indicator on serial port) the power light turns steady on and the board will resume fine, however, after 5-10 sleep/resume cycles (it is irregular), the board will lock up instead of resuming. This is a fresh installation of XP with no extra software. Is there a way to tell if this is a motherboard or operating system issue?


      System specifications:


      D945GSEJT motherboard
      BIOS - JT94510H.86A.0037

      OS - Windows XP/SP3

      Video Driver -

        • 1. Re: D945GSEJT hangs after resuming from S3 sleep

          I have exactly the same problem with my D945GSEJT board. I am using a clean install windows XP sp3 without any other software application. I have set it up as an on demand file server for my home network. The XP is configured to go in S3 sleep mode if there is no activity for 20min and wakes up on a directed packet at LAN card. It all works very well for 2 - 3 days (5-10 sleep/wake cycles) but then at random the system just hangs. I am really frustrated with this problem and any help or response to this problem will be a great help.


          System specifications:


          D945GSEJT motherboard
          BIOS - JT94510H.86A.0037

          OS - Windows XP/SP3

          • 2. Re: D945GSEJT hangs after resuming from S3 sleep



            I've this problem also.

            Differs in number of stanby/resumes. I've a lot more standby/resumes (20 to 30)

            But after 3 day's it wil lock up.

            Same board , same Bios version, same os , same patchlevel etc.


            But when it happens with my system , i've also to detach the powercord.

            When the systems locks up , putting the system off and on , with the power button , doesn't work.

            The system doesn't boot any more , until i've removed , and put back the 12V power.



            I think you've also the reboot problem.

            When the board has been in standby, and resumed fine , you can't reboot (also lockup)

            This has to do with te (bios/cpu) registers.

            It should have been solved in bios 0.37, but with mine , it doesn't.

            A working workaround i s putting /forceresetreg in startup parameters in XP


            Grts Roel

            • 3. Re: D945GSEJT hangs after resuming from S3 sleep



              Maybe someone else has also found something.

              But i've found that this problem has to do with the disk setup.


              With my system the problem occurs in the following setup:

              primary : 2 GB IDE flash module 44p (trancend)

              secondary : 160 GB SATA samsung 2,5" disk (as native)


              When i unplug the SATA disk , and run only on the ide flash module , its working fine.


              Can anybody who has this problem , tell what disk setup is used ?

              • 4. Re: D945GSEJT hangs after resuming from S3 sleep

                Well I have yet to find a solution for this nasty problem. I cannot use PATA drives as i only have SATA drives. I have one 2.5 160GB drive which has the active and boot partition. The other one is a 3.5 1TB drive which is used for storage. I am also running an Apache Tomcat Server to host my websites on this system. I have confiured this XP machine to go in S3 while inactive and allowed the NIC to bring the system back to full power on a directed LAN packet. This setup works very nicely for 3 or so days (I have not tried to count the exact number of sleep/wake cycles yet but i guess it would be around 10-20 times). I orignally posted in this forum in hope that someone from Intel will probably suggest a solution but that has not happend yet. I also check for any BIOS update from intel on daily bases now. I also request other people who are facing the similar problem with this board to register this issue by posting in this thread.


                PS. anyone from Intel reading this thread, please respond to this issue with a solution.

                • 5. Re: D945GSEJT hangs after resuming from S3 sleep



                  Sorry for the misunderstanding.

                  But my machine just hung up, with only the 44p ide drive used.


                  I would like to know what happens if your machine hangs.

                  Do you have to detach te 12 power ?

                  Pressing the power button (which is connected to the board) doesn't work in my case.

                  When the machne hangs , pressing the power button for more than 4 seconds , turns the machine of (standby led stays on)

                  But when I turn it on with the power button , the machine still hangs.

                  After detaching the 12v power , and put it back. I can boot the board again.

                  • 6. Re: D945GSEJT hangs after resuming from S3 sleep

                    Hello Cuppie,


                    I also cannot use the power button when it hangs. The power button seems to have no effect but fortunately my case has a reset button and that always works. I have not tried to hold the power button for 4 seconds.

                    • 7. Re: D945GSEJT hangs after resuming from S3 sleep

                      Hi Rehan,


                      I've a couple of questions.


                      - Do you have the same problem , with a warm restart (after the board has been in standby , and resumed fine) ?

                      - Is it possible for to test the powerbutton issue when the machine hangs ?

                      - In what mode do you use the sata ports in bios (ahci / native etc)

                      - What is the disk / driver version in windows , of the sata disks/controller ?


                      Kind regards,



                      • 8. Re: D945GSEJT hangs after resuming from S3 sleep

                        Hello cuppiie,

                        I think I have the same problem like you. Once the system was in S3, the resume from S3 works fine, but if I try to reboot or shut down the system, windows hangs on the blue shut down screen (with the message "windows is shutting down" or similar).


                        I also have a clean XP SP3 installation with only the intel drivers for chipset, graphics adapter and NIC installed. AHCI driver is NOT installed. When the problem occurs, the NIC seems to be shut off (no more link indication), I have to push the powerbutton for 4 seconds or to push the reset button.

                        At present I use PATA-HDD which is connectet to SATA0-port via a converter. In BIOS ATA/IDE mode is set to Native, nothing changes when I change it to Legacy.

                        The driver version of my disk-controller (Ultra-ATA ans Serial ATA) is


                        No information from INTEL avilable on this issue??

                        • 9. Re: D945GSEJT hangs after resuming from S3 sleep

                          Hi Dreifuss,


                          First of all , there are 2 problems when installing XP SP3 on this D945GSEJT board.

                          1. Warm reboot when XP has been in standby mode , and resumed fine (this is what you mention)

                          2. After many standby and resumes , the D945GSEJT board hangs


                          Problem 1.


                          For this i've made a case by Intel (Case 9291767) a few months ago.

                          This problem is only with XP. Vista and Windows 7 do not have this problem.

                          An Intel engineer was able to reproduce the problem. So there should come a fix , but he couldn't promise me.

                          So I start finding a workaround. So I found one.

                          This is described in Microsofts KB822624 article. (adding /forceresetreg to your XP startup parameters)

                          So I put this information also in Intels Case.

                          The Intel engineer send this info to the development.

                          After a few weeks they released a new bios (0.37)

                          In the release notes they talk about register resets, So it should have been solved. But in mine setup it doesn't. So I still use the /forceresetreg parameter.


                          The shutdown problem (after resume) that you mention , is not known by me.

                          Shutdown after standby/resume was always working fine. (even without /forceresetreg)

                          So let me know if I'm right.


                          Problem 2.

                          When resuming many times. The board seems to hang. A hard reset , or Power dispatch is needed. Using the powerbutton (> 4sec.) doesn't work.

                          As far as I can see, the Disk setup is dependend on the number of resume times.

                          When I use only the pata flash drive , i can resume for 3+ day (60+ resumes)

                          When I also connect a SATA disk (AHCI of native doesn't mention) this is about 15 to 30 resumes.

                          For this problem I've not yet opened a case. I still need more info about what is going on.


                          Af workaround I wrote a simple autohotkey script , which I am testing at the moment.

                          This script counts the standby and resume times , after 10 standby/resumes it reboots XP.

                          I write the standby - resume times in a text file. And also a reboot is logged.

                          Here is a copy of my script.

                          If you want to use it , first get autohotkey for compiling it.

                          It's very basicly , change it to your needs.




                          OnMessage(0x218, "WM_POWERBROADCAST")


                          WM_POWERBROADCAST(wParam, lParam)
                             ; PBT_APMQUERYSUSPEND = 0
                             ; PBT_APMRESUMESUSPEND = 7

                          ; I want to use x globaly so Global is needed


                              ; Check if x has been declared

                              If (x = "") {
                              x := 0
                             If (wParam == 0) {
                                x := x + 1
                                FileAppend,Standby at %A_Now% for the %x% time`n,test.txt
                               ; Check standbytimes

                               If (x == 10) {
                               Sleep, 1000
                                   FileAppend,Reboot at %A_Now%`n,test.txt
                                   Run, "c:\windows\system32\shutdown.exe" -r -t 0

                             ; Resuming form network (7) of powerbutton (18)

                             If (wParam == 7) or (wParam == 18) {
                                Sleep, 1000     
                                FileAppend,Resume at %A_Now% for the %x% time`n,test.txt



                          • 10. Re: D945GSEJT hangs after resuming from S3 sleep

                            Hi Cuppie,


                            yes you're right, problem #1 really occures only when I proceed a warm start after the board was in S3. I did some further tests to verify this, so my initial complaint was not detailed enough. I did not yet try the /forceresetreg -switch, but I will test it.


                            Just to say that I also have BIOS version 037 installed...


                            Problem #2 is not (yet) known by me as my application or usage does not require 24/7 operation. My D945GSEJT shall replace my old P4 file server and I usually turn it off when I'm not at home. So I suppose I will never have that number of standby/resume cycluses withou a reboot. Nevertheless it's good to know that there are further problems. I will keep your script in mind...


                            In general for me it's really a very annoying issue, as I expected not such basic problems from a manufacturer like Intel.

                            • 11. Re: D945GSEJT hangs after resuming from S3 sleep

                              Hello cuppie and dreifuss,


                              First of all thanks a lot for sharing such valuable information. Well reading through your posts i have came to this conclusion that all the problems that are mentioned exist on this board. However, each of us is experiencing different ones depending on the usage. Here are my experiences:


                              - I have not experienced the warm restart problem as I always use the wall switch to restart the system. Weird I know, and here is the reason. Whenever I try to restart or shutdown the system it hangs on the "Windows is shutting down" screen. This is the problem that dreifuss also mention and I am seeing it all the time.


                              - The second problem is that the system hangs after a x number of sleep/resume cycles. Whenever this happens I cannot use the powerbutton for 4 sec to reset the system although the reset button works fine. I am using 2 sata drives in native mode. I suspect that there is a fixed number of sleep/resume cycles after which the system hangs and intend to use the script by cuppie determine that number.


                              I have not yet used the /forceresetreg switch to see if that will help fixing the shutdown problem.



                              • 12. Re: D945GSEJT hangs after resuming from S3 sleep

                                Hi cuppie and rehan,


                                I've tested the */forceresetreg* switch and now it works as expected. Warm start after S3 is now OK. It's very annoying that there is no information about this issue available from INTEL.


                                Thank you very much cuppie for thiss essential info!

                                • 13. Re: D945GSEJT hangs after resuming from S3 sleep

                                  I've really spend a lot of hours for investigating both problems, so you're both welcome :-)


                                  But I'm quite sure , rehan's wall switch isn't needed anymore when apply'ing the /forceresetreg parameter.


                                  But one thing i've already learned with my test script. I'm rebooting xp every 10 standby counts for now. Even then the machine has hung up right now.

                                  It seems that (warm) rebooting xp doesn't 'clear' the standby problem.

                                  The standby led on the board is always lid when warm rebooting. I've no reset button , but i think the led is off when hitting the reset button, isn't it rehan ?


                                  So rehan when you gonna count standby times , you have to start counting when a reset or powercycle is done.


                                  When rehan is right , and the standby/resume counters are steady , we've enough info to reproduce the problem. With that info , its possible to open a new Case at Intel.


                                  Maybe we can also re-open my previous case.


                                  And I'm also very dissapointed that we all have such issues with a real INTEL mainboard.


                                  Let's hope that everything is being solved !

                                  • 14. Re: D945GSEJT hangs after resuming from S3 sleep



                                    I've just opened a case for the second problem (hang up after resuming many times).

                                    Case number 9453645


                                    I'm glad I spoke to the same Intel engineer (Tobias). He had also handled the previous case (warm reboot after standby)

                                    Tobias gives good feedback , so i think he will be able to reproduce the problem.


                                    I've also mentioned about the previous case , that bios 0.37 didn't fix the first problem (warm reboot after standby)

                                    But here I told him that the / forceresetreg workaround is working fine.


                                    I think Tobias will need a couple of day's for reproducing the problem.

                                    We'll have to wait for it.

                                    As soon as I have new information , i'll place it here.


                                    Kind regards


                                    1 2 Previous Next