8 Replies Latest reply on May 20, 2015 8:53 AM by aleki_intel

    750 SSD Installing Win 7 driver issue

    astrosteve

      I have the 750 SSD PCIe card and put it into a new computer with a MSI X99A Mpower board, I have the latest BIOS installed.  When I get to the part about loading the driver for the 750 SSD, it says it can't load the driver (after seeing the directory on the CD, and the little progress bar moves along like it's doing something).  This happens with the little Intel CD that came with the drive, or the latest x64 drivers from Intel's site.

       

      I read something about changing the boot setting to UEFI only (it was Legacy/UEFI), but when I try that, it puts me into some command line prompt, that I have no idea what it is.

       

      Any ideas?  I'd like to be able to load a fresh install of Windows 7 onto this computer.  I appreciate any help you can give.

        • 1. Re: 750 SSD Installing Win 7 driver issue
          aleki_intel

          Hello astrosteve,

           

          Before we go any further we recommend that you look at these links first. Make sure your board is compatible with this drive.

          Intel® SSD 750 Series — Frequently Asked Questions (FAQ)

          Intel® SSD 750 Series — Tested Motherboards

          • 2. Re: 750 SSD Installing Win 7 driver issue
            astrosteve

            Windows 10 sees the 750 just fine, so the motherboard supports the board just fine.  It's the Windows 7 drivers that plain just don't work when trying to load a new copy of Windows 7 on that drive.

            • 3. Re: 750 SSD Installing Win 7 driver issue
              aleki_intel

              astrosteve,

               

              Could you please provide full information on this system?

              • 4. Re: 750 SSD Installing Win 7 driver issue
                aleki_intel

                Astrosteve,

                 

                Make sure your Windows is 64 bit and that you have the NVMe driver. MSI has added NVMe support to all their Intel(R) 9 series chipset based systems as you can confirm here: MSI Global - The best gaming gears maker in the world - Now, how you are installing may matter. A USB thumb drive is not easily formatted for the uEFI install required here. If you are using the 64 bit Windows 7 DVD and picking up uEFI DVD as the boot drive, that should not be an issue.

                Another possibility here is to make sure the BIOS is updated. A 32 bit OS will not boot an NVMe device.

                • 5. Re: 750 SSD Installing Win 7 driver issue
                  astrosteve

                  Ah, I am using a USB thumb drive, so that may be the issue.  Let me try from the original DVD.  That works, past that issue anyway.  Now it creates partitions, then says the motherboard won't be able to boot from them.  So I loaded Win 10 RC installation, and it said it couldn't boot from those Win 7 partitions either.  So I deleted those, and had the Win 10 RC Installation create partitions, and it said those were fine.  So I went back to Win 7 installation, hoping it would like the partitions Win 10 created, but it said it wouldn't be able to boot from those either.  I was able to fully install Win 10 RC with no issues.  But I really want to install Win 7 for now.

                   

                  System info: Intel i7 5820K cpu, MSI X99A Mpower motherboard, with G Skill 8GB 2666 memory (32GB total), and a Sapphire Radeon R7 240 video card.  Trying to load 64 bit Windows 7.

                   

                  Software: Latest BIOS for the X99A motherboard, and I tried the Intel 750 CD that came with the drive, as well as the latest drivers for the 750 SSD.

                  • 6. Re: 750 SSD Installing Win 7 driver issue
                    aleki_intel

                    Hello astrosteve,

                     

                    Please try to select the u-EFI DVD boot from the boot devices menu.

                    • 7. Re: 750 SSD Installing Win 7 driver issue
                      astrosteve

                      I think I got it!  Win 7 is loading now.  Understanding that UEFI expects GPT disks only and not MBR disks helped me, and making sure I was booting the DVD as UEFI.  It still won't load the OS onto the 750 after loading the drivers was a bit I found on the internet  by the user k4nth posted on May 6, 2009:

                       

                      1. Load the RAID driver from CD. (Vista driver will work)    <ie: in my case Intel 750 driver and Windows 7>

                      2. Install the driver and create partitions.

                      3. Remove the driver CD and insert the Windows 7 DVD.

                      4. Click on Refresh and the error should disappear.


                      Once I did the above 4 steps, then I was allowed to choose the 750 drive and start loading the OS. 


                      Oh, one more thing: I had a regular hard drive in there, and instead of creating the 4 partitions, one time it saw the System partition on the regular hard drive and didn't create one on the 750, another time it ended up with two System partitions, and then it got confused.  I had to remove the hard drive, and then delete all the partitions on the 750 and let it create them again.


                      I hope this helps others.  Windows 7 just booted off the Intel 750 SSD!  Thanks for the help!

                      1 of 1 people found this helpful
                      • 8. Re: 750 SSD Installing Win 7 driver issue
                        aleki_intel

                        Hello astrosteve,

                         

                        We are glad to know you resolved the issue. Thank you for sharing your solution here so other users can see it, too.

                        If there is anything else we can do for you let us know.