3 Replies Latest reply on Dec 27, 2009 8:16 AM by badihi

    DG41TY No video, no beep, no boot

    bpierini

      Have a new mobo. Replacement actually, and on receipt, connected the main power, monitor, one stick of RAM and keyboard. Got the Intel logo, so shut it down and installed it. Would not boot, beep or show video. RAM is known good (tested in a DG43), video card is GEForce 9500 GT, processor is core 2 duo. If I remove RAM, get three beeps, indicating the processor is happy and mobo is installed OK. One thread indicated an old BIOS, but can't figure out how to update with no video, no apparent POST, no errors or beep codes. I suspect the BIOS turned off video with the installation of the video card. I left the mobo with nothing plugged into it and the battery removed overnight (to reset the bios) with no success. Right now with one stick of RAM, onboard video and the processor, get nothing. No beep, no video, no boot.

      Ideas or help?

      Thanks

      Bill

        • 1. Re: DG41TY No video, no beep, no boot
          ellefolk

          Hello,

          I have exactly the same problem; DG41TY mobo, Intel core 2 Quad processor, GeForce 9500 GT, 4 GB ram and I have no video even removing the GeFroce and connecting my monitor directly to the mobo integrated video subsystem.

           

          To restore your BIOS try this http://www.intel.com/support/motherboards/desktop/sb/CS-023360.htm it doesn’t work for me but maybe you get better results.

           

          Any help?

           

          Walter

           

          1 of 1 people found this helpful
          • 2. Re: DG41TY No video, no beep, no boot
            bpierini

            Hi, Walter. Thanks for the reply. I had tried to "fix" the bios earlier, with no luck. However, this time I had some success. The first time, system complained that the battery was removed (I had taken it out) and the clock was wrong (go figure, nothing to check against.) Then it suposedly updated the bios (6-26-09), had monitor, keyboard and a beep as the USB was loading the bio file. No luck on a reboot. Still nothing. Tried an ubuntu bootable usb, and a windows bootable DVD, but nothing comes to life. However, everytime I insert the usb with the bio file, have keyboard, monitor and a nice startup beep. This is aggravating, but at least you gaveme hope that something might eventually work.

            Thanks

            Bill

            • 3. Re: DG41TY No video, no beep, no boot
              badihi

              I have the same problem with the DG41TY mobo with Intel processor core 2 quad and one DDR2 2GB memory.

              No video card. I use the on-board DVI interface.

              The system worked for a couple of months and now stopped, with no beep, no video, and no boot.

              I tried the procedure for BIOS recovery, but nothing happens.