2 Replies Latest reply on May 14, 2015 12:26 PM by rJ@logicnow

    No network in WinPE

    rJ@logicnow

      I am attempting to reimage a NUC5i7RYH with SCCM 2012 R2.  We have been using DC53427HYE machines, but are looking to shift to ordering the i7 models now that they are out.  We have an image built with SCCM for the DC53427HYE that automates our image builds.  It works without issue.

      With the NUC5i7RYH, I am able to get the machine to PXE boot and pull down the WinPE image to reboot into WinPE. The issue comes in that the machine immediately reboots.  This is typically caused by not having a network driver installed, so I use F8 to pull up the CMD prompt.  I try ipconfig /all and find that there are no registered network connections. 

       

      Simple enough.  I load the extracted drivers for Win7 onto a thumb drive and start using DRVLOAD to register the following :

       

      iansw60e.inf

      ifb63x64.inf

      ifcoemp.inf

      ifcoepr.inf

      ifcoevb.inf

      ifm63x64.inf

      ifp63x64.inf

       

      Some of them load, some of them note that they have already been loaded.  After each command, I use "wpeutil initializenetwork" to try and register a network connection, but it does not load. 

       

      Never Surrender!  I then add the following drivers to my Boot Image in WinPE using the SCCM Console :

       

      Intel (R) Advanced Network Services Virtual Adapter

      Intel (R) Advanced Network Services Protocol

      Intel (R) Ethernet FCoE Protocol Driver

      Intel (R) Ethernet LLDP Protocol Driver

      Intel (R) 8 Series/C220 Chipset Family SATA ACHI Controller

       

      Verified that Bios is set to use ACHI Chipset SATA Mode.  Rebooted into WinPE, and still experience the same issue. 

       

      Launch notepad to verify that drives are showing up, and see that there is an X: drive, and a C: drive (USB that I used to load drivers).   From there, I was able to run notepad.exe and check the SMSTS.log file and determine that the exit code is from not being able to TFTP the files from the distribution point.  That would make sense seeing as how there is no registered network device.

       

      Any thoughts?


        • 1. Re: No network in WinPE
          Intel_Paul

          Thanks for contacting Intel rJ@logicnow,

           

          I am very familiar with SCCM and other system management tools. I am curious if you have tried loading a bare copy of windows onto this system? I am wondering if the issue is related solely to the WinPE environment or if it is a driver/hardware issue and would just like to narrow it down a little bit. Have you tried using the generic Windows networking drivers instead of the Intel Specific drivers? I ask because I know in the past my own WinPE images ran into problems with a variety of hardware and the official drivers not loading correctly.

           

          As well, how many units do you have of this model? I am curious if this is happening on a single unit or several units?

           

          I look forward to your feedback.

           

          Thanks,

           

          Paul

          Intel Customer Support

          NUC Product Support Engineer

          • 2. Re: No network in WinPE
            rJ@logicnow

            Hi Paul,

             

            Thanks for the reply.We have successfully loaded the drivers onto a Windows OS.  And have successfully installed all of the other drivers once an OS is installed.  We have even verified this with a second NUC5i7RYH, to rule out other issues.  The issue only persists in the WinPE environment.  We are also having a hard time getting the required device drivers separated from their .exe installers to be used during the SCCM reimaging process.

             

            The only drivers that I could get to work were the I218-V drivers.  Once I loaded those into the Boot image, the Task Sequence was able to load correctly.  If you haven't seen the following link, it was clutch in solving this issue.

             

            http://www.niallbrady.com/2011/08/31/missing-nic-driver-in-winpe-boot-image-no-problem/

             

            Now I'm on to pulling the device drivers for all of the other components.  Hope this helps others!