1 Reply Latest reply on May 12, 2015 12:49 PM by allan_intel

    All USB Ports are not working anymore

    arahmaninaam

      Hi,

       

      I have recently updated Intel USB 3.0 eXtensible Host Controller Driver by a Software called Driver Max. This Software helped me very well to keep my drivers

      up to date. But today unfortunately after I have updated & Installed Intel USB 3.0 eXtensible Host Controller Driver, all the USB Hubs disabled automatically.

       

      I have Disabled & Enabled all the USB Hubs from Device manager, there is no change. I have even uninstaller & restarted the machine again, still there is no change. It turns out, that all the USB ports are now almost dead. I have tried to connect several mouse & USB flash drive, there LEDs goes on & stable. I have tried to Install Microsoft Fix it application inorder to solve the Problem, but there I have got an error message, saying; "It no compatible this you system application". I also have downloaded & Installed Intel Driver Update Utility, but unfortunately I haven't found update for Intel USB 3.0 eXtensible Host Controller Driver. I Have found update for Graphic, Wireless & Bluetooth.

       

      Now I want solution to make my all USB Hubs back into work again. I have 2 USB 2.0 ports & 1 USB 3.0 port. My notebook is from ASUS S550CM-CJ026H model (ultrabook), running Windows 8.1 Pro (not OEM version of Windows). So is there any possible way to downgrade USB 3.0 eXtensible Host Controller? Or any other way to make all the ports work as it was before?

       

      Thank you.