13 Replies Latest reply on Jun 30, 2015 1:59 PM by Jacob_Nash

    Flash Tool Lite issues

    mikemoy

      In following the directions for flashing here:

      https://software.intel.com/en-us/articles/flash-tool-lite-user-manual

       

      When I plug in the USB cable the Flash tool shows that its connected but only for about 2 seconds, then shows disconnected.

      After the board is done booting I do have access to the drive onboard through windows. So I know its live.

      What is the problem here ?

       

       

      Also, Intel, please don't mismatch names. The program is called PhoneFlashToolLite, so why you are calling it Flash Tool Lite, I have no idea. It's only going to cause confusion.

        • 1. Re: Flash Tool Lite issues
          Intel_Peter

          Hello mikemoy,

           

          Could try to flash your board again with the Flash Tool Lite? But this time try to start a PuTTY to see the process. The process takes a while so you will be able to see the whole process and if there's something wrong with it. Let us know if you see any odd output.

          Also, thank you for your feedback on the tool's name, we will make sure to pass it.

           

          Peter.

          • 2. Re: Flash Tool Lite issues
            Intel_Peter

            mikemoy,

             

            Try the following steps:

            1. Unplug your Edison from PC

            2. Start the Flash Tool Lite

            3. Browse to Edison.json file

            4. Click start flashing

            5. Plug your Edison to your PC

             

            Let us know if you notice any difference.

             

            Peter.

            • 3. Re: Flash Tool Lite issues
              CMata_Intel

              Hi mikemoy

               

              Have you been able to use the Flash Tool Lite? Did you try with Peter's suggestions?

               

              Regards;

              CMata

              • 4. Re: Flash Tool Lite issues
                mikemoy

                This method worked. Thank you.

                • 5. Re: Flash Tool Lite issues
                  KurtE

                  I have had mixed luck here.

                   

                  This is a Windows 7 machine.  I have installed several versions of Edison software....  With this release I have been seeing several times when I plug in an Edison, I get device software install messages, that fail.  So I have tried just downloading the device driver install program and ran it, which uninstalled and then reinstalled drivers.  Still failed.  So I ran the All In one installer again.  I choose to uninstall everything.  It got I think up to step 5 of 8, and the program aborted(faulted).  I rebooted, ran again and it completed the uninstall.  I then ran again to do a complete install, including eclipse.

                   

                  My Arduino Edison was failing to have it's image updated before, but did go through successfully.  So I tried it with one with newer mini breakout boards (replacement for 2nd one that died...).  It failed

                  05/16/15 08:30:00.316 INFO : Intel(R) Phone Flash Tool Lite V 5.2.4.0 x86 (build on Monday April 27th 2015, 16:29:59 UTC)

                  05/16/15 08:30:00.316 INFO : Using xFSTK Downloader version: 1.8.0

                  05/16/15 08:30:00.348 INFO : Using DFU Downloader version: 0.8-msvc

                  05/16/15 08:30:00.379 INFO : Using Android Debug Bridge version 1.0.32

                  05/16/15 08:30:00.379 INFO : OS version detected: Windows 7 (x64)

                  05/16/15 08:30:00.379 INFO : SSL supported: No

                  05/16/15 08:30:00.441 INFO : Disk space available on drive C:/ : 609.54 GB

                  05/16/15 08:30:00.519 INFO : Adb and fastboot binaries OK

                  05/16/15 08:30:00.706 INFO : Phone Flash Tool Lite initialized successfully

                  05/16/15 08:30:05.184 INFO : Ready to flash!

                  05/16/15 08:30:05.184 INFO : Flash file C:\Users\Kurt\Documents\edison-image-ww18-15\FlashEdison.json [RNDIS] loaded

                  05/16/15 08:30:09.442 INFO : [Port -1] Starting flash ...

                  05/16/15 08:30:09.442 INFO : [Port -1] Running `Notify 'C:\Users\Kurt\Documents\edison-image-ww18-15\helper\helper.html'` command

                  05/16/15 08:30:09.614 INFO : Displaying 'file:///C:/Users/Kurt/Documents/edison-image-ww18-15/helper/helper.html' during 42000 ms

                  05/16/15 08:30:09.614 INFO : [Port -1] Command `Notify 'C:\Users\Kurt\Documents\edison-image-ww18-15\helper\helper.html'` succeed

                  05/16/15 08:30:09.614 INFO : [Port -1] Running `Wait for device with status dnx_fw on port -1` command

                  05/16/15 08:30:18.146 INFO : [Port 0/3] Command `Wait for device with status dnx_fw on port -1` succeed

                  05/16/15 08:30:18.146 INFO : [Port 0/3] Running `Notify 'Edison board plugged'` command

                  05/16/15 08:30:18.336 INFO : Displaying 'Edison board plugged'' during 5000 ms

                  05/16/15 08:30:18.370 INFO : [Port 0/3] Command `Notify 'Edison board plugged'` succeed

                  05/16/15 08:30:18.370 INFO : [Port 0/3] Running `"xfstkFlashTool.exe" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_fwr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_ifwi-dbg-00.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_osr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.img" "0x80000007" "none" "none"` command

                  05/16/15 08:30:18.425 INFO : [Port 0/3] Disabling xFSTK Misc DnX

                  05/16/15 08:30:18.425 INFO : [Port 0/3] Disabling xFSTK wipe out ifwi option

                  05/16/15 08:30:18.425 INFO : [Port 0/3] Using xFSTK Solo interface (new API)

                  05/16/15 08:30:18.425 INFO : [Port 0/3] xFSTK Soft Fuse not set

                  05/16/15 08:30:18.425 INFO : [Port 0/3] XFSTK Downloader API 1.8.0

                  05/16/15 08:30:18.425 INFO : [Port 0/3] Copyright (c) 2015 Intel Corporation

                  05/16/15 08:30:18.425 INFO : [Port 0/3] fwdnx -- C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_fwr.bin

                  05/16/15 08:30:18.425 INFO : [Port 0/3] fwimage -- C:\Users\Kurt\Documents\edison-image-ww18-15\edison_ifwi-dbg-00.bin

                  05/16/15 08:30:18.425 INFO : [Port 0/3] osdnx -- C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_osr.bin

                  05/16/15 08:30:18.425 INFO : [Port 0/3] osimage -- C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.img

                  05/16/15 08:30:18.425 INFO : [Port 0/3] gpflags -- 0x80000007

                  05/16/15 08:30:18.425 INFO : [Port 0/3] softfuse --

                  05/16/15 08:30:18.495 INFO : [Port 0/3] XFSTK-STATUS--Detecting Intel Device - Attempt #0

                  05/16/15 08:30:19.625 INFO : [Port 0/3] ....XFSTK-LOG--virtual bool MerrifieldDownloader::SetDevice(IGenericDevice*)

                  05/16/15 08:30:19.625 INFO : [Port 0/3] Initiating download...

                  05/16/15 08:30:19.627 INFO : [Port 0/3] XFSTK-STATUS--FW(Miscdnx) download is in progress ...

                  05/16/15 08:30:19.627 INFO : [Port 0/3] XFSTK-STATUS--FW: Sending DnX DCFI00 ...

                  05/16/15 08:30:22.470 INFO : [Port 0/3] XFSTK-STATUS--Error Code: 0 - Success

                  05/16/15 08:30:22.471 INFO : [Port 0/3] XFSTK-STATUS--Firmware download completed. Continuing to OS...

                  05/16/15 08:30:32.797 INFO : [Port 0/3] XFSTK-STATUS--Reconnecting to device - Attempt #1

                  05/16/15 08:30:33.999 INFO : [Port 0/3] XFSTK-STATUS--POS download is in progress ...

                  05/16/15 08:30:36.771 INFO : [Port 0/3] XFSTK-STATUS--Error Code: 0 - Success

                  05/16/15 08:30:36.771 INFO : [Port 0/3] XFSTK-STATUS--Firmware and OS download completed.

                  05/16/15 08:30:36.771 INFO : [Port 0/3] XFSTK: Transfer Completed Successfully.

                  05/16/15 08:30:36.771 INFO : [Port 0/3] Success: Download of FW Completed.

                  05/16/15 08:30:36.771 INFO : [Port 0/3] xfstkFlashTool exited with success

                  05/16/15 08:30:36.771 INFO : [Port 0/3] Command `"xfstkFlashTool.exe" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_fwr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_ifwi-dbg-00.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_osr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.img" "0x80000007" "none" "none"` succeed

                  05/16/15 08:30:36.771 INFO : [Port 0/3] Running `Wait for device with status pos on port 0/3` command

                  05/16/15 08:30:50.385 INFO : [Port 0/3] Command `Wait for device with status pos on port 0/3` succeed

                  05/16/15 08:30:50.385 INFO : [Port 0/3] Running `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` command

                  05/16/15 08:30:50.447 WARNING: [Port 0/3] Command `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` failed

                  05/16/15 08:30:50.447 INFO : [Port 0/3] Retrying `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` command

                  05/16/15 08:30:50.510 ERROR : [Port 0/3] Command `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` failed

                  05/16/15 08:30:50.510 ERROR : [Port 0/3] Flash failed (Command type: DFU)

                  05/16/15 08:31:17.295 INFO : [Port 0/3] Start flashing the flash configuration with dnx_fw start state for

                  05/16/15 08:31:17.295 INFO : [Port 0/3] Starting flash ...

                  05/16/15 08:31:17.295 INFO : [Port 0/3] Running `Notify 'C:\Users\Kurt\Documents\edison-image-ww18-15\helper\helper.html'` command

                  05/16/15 08:31:17.623 INFO : Displaying 'file:///C:/Users/Kurt/Documents/edison-image-ww18-15/helper/helper.html' during 42000 ms

                  05/16/15 08:31:17.638 INFO : [Port 0/3] Command `Notify 'C:\Users\Kurt\Documents\edison-image-ww18-15\helper\helper.html'` succeed

                  05/16/15 08:31:17.638 INFO : [Port 0/3] Running `Wait for device with status dnx_fw on port 0/3` command

                  05/16/15 08:31:26.860 INFO : [Port 0/3] Command `Wait for device with status dnx_fw on port 0/3` succeed

                  05/16/15 08:31:26.860 INFO : [Port 0/3] Running `Notify 'Edison board plugged'` command

                  05/16/15 08:31:26.869 INFO : Displaying 'Edison board plugged'' during 5000 ms

                  05/16/15 08:31:26.873 INFO : [Port 0/3] Command `Notify 'Edison board plugged'` succeed

                  05/16/15 08:31:26.873 INFO : [Port 0/3] Running `"xfstkFlashTool.exe" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_fwr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_ifwi-dbg-00.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_osr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.img" "0x80000007" "none" "none"` command

                  05/16/15 08:31:26.900 INFO : [Port 0/3] Disabling xFSTK Misc DnX

                  05/16/15 08:31:26.900 INFO : [Port 0/3] Disabling xFSTK wipe out ifwi option

                  05/16/15 08:31:26.900 INFO : [Port 0/3] Using xFSTK Solo interface (new API)

                  05/16/15 08:31:26.900 INFO : [Port 0/3] xFSTK Soft Fuse not set

                  05/16/15 08:31:26.900 INFO : [Port 0/3] XFSTK Downloader API 1.8.0

                  05/16/15 08:31:26.900 INFO : [Port 0/3] Copyright (c) 2015 Intel Corporation

                  05/16/15 08:31:26.900 INFO : [Port 0/3] fwdnx -- C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_fwr.bin

                  05/16/15 08:31:26.900 INFO : [Port 0/3] fwimage -- C:\Users\Kurt\Documents\edison-image-ww18-15\edison_ifwi-dbg-00.bin

                  05/16/15 08:31:26.900 INFO : [Port 0/3] osdnx -- C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_osr.bin

                  05/16/15 08:31:26.900 INFO : [Port 0/3] osimage -- C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.img

                  05/16/15 08:31:26.900 INFO : [Port 0/3] gpflags -- 0x80000007

                  05/16/15 08:31:26.900 INFO : [Port 0/3] softfuse --

                  05/16/15 08:31:26.970 INFO : [Port 0/3] XFSTK-STATUS--Detecting Intel Device - Attempt #0

                  05/16/15 08:31:28.100 INFO : [Port 0/3] ....XFSTK-LOG--virtual bool MerrifieldDownloader::SetDevice(IGenericDevice*)

                  05/16/15 08:31:28.100 INFO : [Port 0/3] Initiating download...

                  05/16/15 08:31:28.104 INFO : [Port 0/3] XFSTK-STATUS--FW(Miscdnx) download is in progress ...

                  05/16/15 08:31:28.105 INFO : [Port 0/3] XFSTK-STATUS--FW: Sending DnX DCFI00 ...

                  05/16/15 08:31:30.958 INFO : [Port 0/3] XFSTK-STATUS--Error Code: 0 - Success

                  05/16/15 08:31:30.958 INFO : [Port 0/3] XFSTK-STATUS--Firmware download completed. Continuing to OS...

                  05/16/15 08:31:41.269 INFO : [Port 0/3] XFSTK-STATUS--Reconnecting to device - Attempt #1

                  05/16/15 08:31:42.471 INFO : [Port 0/3] XFSTK-STATUS--POS download is in progress ...

                  05/16/15 08:31:45.258 INFO : [Port 0/3] XFSTK-STATUS--Error Code: 0 - Success

                  05/16/15 08:31:45.258 INFO : [Port 0/3] XFSTK-STATUS--Firmware and OS download completed.

                  05/16/15 08:31:45.258 INFO : [Port 0/3] XFSTK: Transfer Completed Successfully.

                  05/16/15 08:31:45.258 INFO : [Port 0/3] Success: Download of FW Completed.

                  05/16/15 08:31:45.258 INFO : [Port 0/3] xfstkFlashTool exited with success

                  05/16/15 08:31:45.258 INFO : [Port 0/3] Command `"xfstkFlashTool.exe" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_fwr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_ifwi-dbg-00.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\edison_dnx_osr.bin" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.img" "0x80000007" "none" "none"` succeed

                  05/16/15 08:31:45.258 INFO : [Port 0/3] Running `Wait for device with status pos on port 0/3` command

                  05/16/15 08:31:59.203 INFO : [Port 0/3] Command `Wait for device with status pos on port 0/3` succeed

                  05/16/15 08:31:59.203 INFO : [Port 0/3] Running `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` command

                  05/16/15 08:31:59.266 WARNING: [Port 0/3] Command `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` failed

                  05/16/15 08:31:59.266 INFO : [Port 0/3] Retrying `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` command

                  05/16/15 08:31:59.328 ERROR : [Port 0/3] Command `"C:\Program Files (x86)\Intel\Phone Flash Tool Lite\dfu-util.exe" "--alt" "u-boot0" "-D" "C:\Users\Kurt\Documents\edison-image-ww18-15\u-boot-edison.bin" "-t" "4096" "-d" "8087:0a99"` failed

                  05/16/15 08:31:59.328 ERROR : [Port 0/3] Flash failed (Command type: DFU)

                  So to make sure the device was OK, took it to my Ubuntu 14.04 machine with same image files, and did the: sudo ./flashall.sh

                  It completed fine.  So then curious, took it back over to window 7 machine and again trying to install device drivers.

                   

                  First Intel Edison USB Composit Device(COM34)   Succeeded.

                  Then Intel Edison USB RNDIS Device           failed.

                   

                  BUT: then I try to flash this one again with the tool and now appears like it is succeeding?  Could it be that the tool has an issue with boards that were flashed with kernels versus ones that we download?

                   

                  Also after install with tool no longer getting the driver messages?  Something different between tool and flashall.sh on linux?

                   

                  The good news is I did finally get it to flash.

                  • 6. Re: Flash Tool Lite issues
                    MauroAssis

                    I tryied Peter suggestion but I got the error message:

                     

                    ERROR : [Port 2/1] Command `"xfstkFlashTool.exe" "D:\temp\imagem\edison_dnx_fwr.bin" "D:\temp\imagem\edison_ifwi-dbg-00.bin" "D:\temp\imagem\edison_dnx_osr.bin" "D:\temp\imagem\u-boot-edison.img" "0x80000007" "none" "none"` failed

                    • 7. Re: Flash Tool Lite issues
                      cgarner

                      I am getting the same message as Mauro

                      • 8. Re: Flash Tool Lite issues
                        wdehoog

                        I too get the same error.  Tried to flash using RNDIS  (note: after installation of the phoneflashtoollite I had to specify to use the Microsoft Driver for the RNDIS device.) The last message that appears on the serial terminal is

                        ******************************
                        PSH KERNEL VERSION: b0182b2b
                                        WR: 20104000
                        ******************************
                        
                        SCU IPC: 0x800000d0  0xfffce92c
                        
                        PSH miaHOB version: TNG.B0.VVBD.0000000c
                        
                        microkernel built 11:24:08 Feb  5 2015
                        
                        ******* PSH loader *******
                        PCM page cache size = 192 KB
                        Cache Constraint = 0 Pages
                        Arming IPC driver ..
                        Adding page store pool ..
                        PagestoreAddr(IMR Start Address) = 0x04899000
                        pageStoreSize(IMR Size)          = 0x00080000
                        
                        *** Ready to receive application ***
                        
                        
                        U-Boot 2014.04 (May 08 2015 - 15:14:34)
                        
                               Watchdog enabled
                        DRAM:  980.6 MiB
                        MMC:   tangier_sdhci: 0
                        In:    serial
                        Out:   serial
                        Err:   serial
                        Writing to redundant MMC(0)... done
                        Writing to MMC(0)... done
                        Hit any key to stop autoboot:  0
                        Target:ifwi
                        Partitioning using GPT
                        Writing GPT: success!
                        Saving Environment to MMC...
                        Writing to redundant MMC(0)... done
                        Partitioning already done...
                        Saving Environment to MMC...
                        Writing to MMC(0)... done
                        GADGET DRIVER: usb_dnl_dfu
                        
                        • 9. Re: Flash Tool Lite issues
                          Intel_Peter

                          Hello wdehoog,

                           

                          You could try the method cgarner used in Edison Won't Boot After Trying Flash Tool Lite.

                           

                          Peter.

                          • 10. Re: Flash Tool Lite issues
                            wdehoog

                            Yes this method worked. But what caused Phone Flash Tool Lite to fail on windows? And why cannot the tool handle this situation?

                            • 11. Re: Flash Tool Lite issues
                              Intel_Peter

                              Well it could have been caused by a lot of different reasons. For instance, some of your image's files could have been corrupted, or maybe you were powering the board only with the USB cable and the USB port in which the board was plugged to could have failed to provide enough power to the board. As I said, it could have been a lot of different reasons; it's hard to tell without knowing the environmental details.

                               

                              Peter.

                              • 12. Re: Flash Tool Lite issues
                                wdehoog

                                It could indeed have been a power issue since the voltage regulator powerded by the 12V external supply was damaged. But then my 2nd remains: why cannot Phone Flash Tool Lite handle this situation and do I have to use the other tools? Just curious.

                                • 13. Re: Flash Tool Lite issues
                                  Jacob_Nash

                                  I have seem to run into errors when I use any USB hubs. Maybe not needed info but a good BKM.