2 Replies Latest reply on May 28, 2015 3:12 PM by chnyc

    Bluetooth on Edison Ubilinux troubleshooting

    chnyc

      Hello,

       

      I've posted a similar message to the Ubilinux/Emutex Labs forum but haven't received a response, yet.

       

      I'm simply trying to connect a Bluetooth speaker to Edison running Ubilinux (3.10.17-yocto-standard-r2), and am unable to get a connection. The speaker is recognized and pairs successfully, but the connection keeps dropping. I've also tried with more than one different BT speaker, and an iPhone but had the same results.

       

      Using bluetoothctl, the error is the following:

       

      [bluetooth]# connect XX:XX:XX:XX:XX:XX

      Attempting to connect to XX:XX:XX:XX:XX:XX

      Failed to connect: org.bluez.Error.Failed

       

      Here are the threads I've tried on the Intel side:

       

      ubilinux (Debian) now available from Emutex Labs

      https://communities.intel.com/thread/56092

      https://communities.intel.com/message/257308

      https://communities.intel.com/thread/57254

      https://communities.intel.com/message/282084

      https://communities.intel.com/message/264410

      https://communities.intel.com/message/273906

      https://communities.intel.com/thread/58955

       

      Additionally, I've tried using the hci toolset directly (without bluetoothctl), but with the same error.

       

      I've also gone through the Intel BT guide Edison, and tried everything suggested (http://download.intel.com/support/edison/sb/edisonbluetooth_331704004.pdf) and still no connection.

       

      I see from the Intel Forums that users showing positive results seem to be using bluez 5.24, whereas the current Ubilinux distro uses 5.27. Could this be the problem?

       

      Has anyone been successful getting a BT speaker + Ubilinux connected using the current 5.27 pkg or any pkg for that matter?

       

      Thanks very much for any suggestions or guidance.

       

      Charles