2 Replies Latest reply on May 1, 2015 7:49 PM by CarlosRafi

    Old Scanner on USB2 for Virtual WinXP mode, USB3 gets in the way.

    CarlosRafi

      I have a brand new Dell Precision 5810 with a Xeon E5-1620 v3 and Win7 64.  Everything is working fine, except my old HP 5470c scanner, HP does not provide any 64 bit drivers for it, not even for Vista.

       

      To make the long story short, I installed MS Virtual PC and created VMs for Win7 32 and WinXP Mode. When I try to attach the USB 2.0 port where the scanner is connected it says it cannot do it.

      To make the story even shorter, I updated the Intel Extensible Host Controller driver to 3.0.5.69 and decided to give it a try right after installing the new drivers without rebooting the machine (we all know that a reboot is not mandatory in all cases right).  And guess what???  It worked on both VMs and I was able to scan just fine.  I was very happy, that is, until I rebooted.  At which point it would not allow me to attach the USB port to the VMs again.  So, I repeated the test, I reinstalled the Intel USB 3.0 eX drivers and again tested without rebooting and it again worked and was able to use the scanner again. So, it seems like when the USB 3.0 drivers are out of the way, the VMs can attach the USB 2.0 ports, consistently, without a problem.

      Rebooted again, and the scanner did not work.  I tried just killing iUSB3mon.exe but that does not do it.  So, my big question is, what component can I temporarily kill or disable to basically get the USB 3.0 drivers out of the way???  Preferably via script. 

       

      I have read that you can accomplish the same thing by turning off USB 3.0 in the Bios but I would not like to have to do that.

      Thanks.  Hope someone can help.