3 Replies Latest reply on May 1, 2015 11:14 AM by Gil@Iron

    Problem with connecting interface to Intel Galileo through ssh

    Gil@Iron

      Hi,

       

      I have a problem: I accidently lost the file: "sshd_config" from the /etc/ssh dir. and thus all the connection config. was lost.

      Is there a way to restore the original file with the original data?

       

      Regards,

      Gil

        • 1. Re: Problem with connecting interface to Intel Galileo through ssh
          wb_Intel

          Hi Gil@Iron,

           

            Thank you for the post. I will forward your inquiry to Galileo support to further assist on this.

           

          rgds,

          wb

          • 2. Re: Problem with connecting interface to Intel Galileo through ssh
            Intel_Peter

            Hello Gil@Iron,

             

            Well, you could get it back if you put the Galileo's image again in the SD Card. Or you could try could try to create a new file with the same content. This is what my sshd_config looks like:

             

            #      $OpenBSD: ssh_config,v 1.25 2009/02/17 01:28:32 djm Exp $
            
            # This is the ssh client system-wide configuration file.  See
            # ssh_config(5) for more information.  This file provides defaults for
            # users, and the values can be changed in per-user configuration files
            # or on the command line.
            
            # Configuration data is parsed as follows:
            #  1. command line options
            #  2. user-specific file
            #  3. system-wide file
            # Any configuration value is only changed the first time it is set.
            # Thus, host-specific definitions should be at the beginning of the
            # configuration file, and defaults at the end.
            
            # Site-wide defaults for some commonly used options.  For a comprehensive
            # list of available options, their meanings and defaults, please see the
            # ssh_config(5) man page.
            
            Host *
              ForwardAgent yes
              ForwardX11 yes
            #  RhostsRSAAuthentication no
            #  RSAAuthentication yes
            #  PasswordAuthentication yes
            #  HostbasedAuthentication no
            #  GSSAPIAuthentication no
            #  GSSAPIDelegateCredentials no
            #  BatchMode no
            #  CheckHostIP yes
            #  AddressFamily any
            #  ConnectTimeout 0
            #  StrictHostKeyChecking ask
            #  IdentityFile ~/.ssh/identity
            #  IdentityFile ~/.ssh/id_rsa
            #  IdentityFile ~/.ssh/id_dsa
            #  Port 22
            #  Protocol 2,1
            #  Cipher 3des
            #  Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
            #  MACs hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160
            #  EscapeChar ~
            #  Tunnel no
            #  TunnelDevice any:any
            #  PermitLocalCommand no
            #  VisualHostKey no
            

             

            Create a new file with the command "vi sshd_config" and paste the lines above in this new file. Then move this file to /etc/ssh/.

             

            Peter.

            • 3. Re: Problem with connecting interface to Intel Galileo through ssh
              Gil@Iron

              Hi Intel_Peter,

               

              Thanks a lot for the help. I tried to copy the lines you posted, and had a problem with lines 20-22.

              I am not sure what is their purpose, but when I removed them, everything worked fine.

               

              Gil