2 Replies Latest reply on Apr 30, 2015 6:41 PM by Todorojo

    I can't submit a service request form.

    Todorojo

      I'm wondering if there's some trick to this... I have tried Chrome, Firefox, and IE and I cannot for the life of me get past the final step. I have checked and rechecked all the necessary boxes and information.

       

      I have been doing a lot of work trying to get my processor to run at decent temperatures but I cannot seem to do so. I originally was running a Noctua CPU cooler on my 4790k but was not able to run anything too intense. I have since upgraded to a full liquid cooled loop and my GPU runs extremely cool (36c even when gaming) but at the stock clock I'm hitting upwards of 85c to sometimes 90c when stress testing or converting video. I tried an article I found in the communities to check TPD values and wattage etc. to try to help but found I was still getting into the 90c ranges so I quickly quit those tests.

       

       

      Is this something I could get a replacement for? Is this normal?

       

       

      My machine is as follows:

      4790k

      Kingston Hyper X 16GB 1866

      MSI Z97S SLI Krait Edition

      MSI Nvidia GTX970

       

       

      EK Waterblocks Supremacy EVO CPU block

      EK Waterblocks GPU block

      2 XSPC Radiators