3 Replies Latest reply on May 4, 2015 6:42 PM by CMata_Intel

    Installing IoTDevKit for Edison.

    AllenCK

      I am running Ubuntu 12.04. I would iike to install an IDE to develop code for my Edison and SparkFun Base Block. I downloaded and installed the latest version dated 02 September 2014. According to the instructions, I am supposed to start it by running the script devkit-launcher.bat. However there was no devkit-launcher.bat but there was:-rwxr-xr-x 1 allen allen  691 Jun  9  2014 devkit-launcher

       

      The instructions state that upon starting the program, I should see a window with a tab labelled" Intel(R) Developer Kit but this is not the case. I also saw on another page that if this page did not appear, I should select IoT Dev kit, from the Help Menu. The help menu does not contain any such entry nor does any of the menus mention "Edison"

      In the

      In the terminal window, this is displayed:

      allen@ubuntu:~/Downloads/iotdk-ide-linux$ ls -l

      total 20

      -rwxr-xr-x 1 allen allen  691 Jun  9  2014 devkit-launcher

      drwxr-xr-x 3 allen allen 4096 Jul 17  2014 devkit-x86

      drwxrwxr-x 9 allen allen 4096 Apr 28 10:25 eclipse-linux

      drwxr-xr-x 4 allen allen 4096 Sep  3  2014 iot-devkit

      drwxr-xr-x 2 allen allen 4096 Jul 18  2014 sdk-relocator

      allen@ubuntu:~/Downloads/iotdk-ide-linux$ ./devkit-launcher

      /home/allen/Downloads/iotdk-ide-linux

      Relocating SDK

      Setting variables

      /opt/microchip/xc8/v1.12/bin:/opt/microchip/xc8/v1.12/bin:/home/allen/Downloads/FWTools/FWTools-2.0.6:/usr/local/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games/home/allen/AndroidADT/adt-bundle-linux/sdk/platform-tools:/home/allen/AndroidADT/adt-bundle-linux/sdk/tools:/home/allen/AndroidADT/adt-bundle-linux/android-ndk-r9c:/home/allen/AndroidADT/adt-bundle-linux/apache-ant/bin:/home/allen/AndroidADT/adt-bundle-linux/android-studio/bin:/home/allen/Downloads/iotdk-ide-linux/devkit-x86/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux/

      allen@ubuntu:~/Downloads/iotdk-ide-linux$ Gtk-Message: Failed to load module "canberra-gtk-module"

       

      What do I need to do to get the development code for Edison?

       

      Message was edited by: Allen Kempe