6 Replies Latest reply on Apr 28, 2015 5:44 PM by Elspin

    Vi cannot edit opkg base-feeds?

    Elspin

      I'm trying to add the following to my /etc/opkg/base-feeds.conf:

       

      src/gz all http://repo.opkg.net/edison/repo/all

      src/gz edison http://repo.opkg.net/edison/repo/allsrc/gz 

      src/gz core2-32 http://repo.opkg.net/edison/repo/allsrc/gz

       

      but vi is unable to write to the file at all. Is there a good reason for this or way around it? Several guides (most recently this one Intel Edison IP Webcam (Step 2)) seem to just imply that you can do that without any special commands, but vi does nothing. I'm logged in as root, and using the exact commands they are. I'm using the default yocto image, if that helps.

        • 1. Re: Vi cannot edit opkg base-feeds?
          mhahn

          Elspin wrote:

           

          vi does nothing.

          what exactly happens? Apart from that I typically replace vi by vim it's working fine for me

          • 2. Re: Vi cannot edit opkg base-feeds?
            Elspin

            When I attempt to do a write (:w) it does nothing, just spits out

            'etc/opkg/base-feeds.conf' 4L, 0C

            When I attempt to quit (:q) it says I have pending changes. Forcing a quit and then re-loading the file shows that I didn't write anything.

            • 3. Re: Vi cannot edit opkg base-feeds?
              CMata_Intel

              Hi Elspin

               

              After

              root@edison:~# vi base-feeds.conf
              

              You should type the letter i, and then you will be able to write in the document after this, press "Esc" and then you can use :wq for saving and quiting or :q! for quiting without saving.

               

              Regards;

              CMata

              • 4. Re: Vi cannot edit opkg base-feeds?
                Elspin

                Hi CMata_Intel, if you read the posts that is what has been attempted, but it's not working. When I have the file edited the way I want, doing :wq does not save and so fails to quit, and just :w will not write. This is working for other files, but not for /etc/opkg/base-feeds.conf, which is what I need to edit

                • 5. Re: Vi cannot edit opkg base-feeds?
                  CMata_Intel

                  Hi Elspin

                   

                  I read the posts but I didn't see that you had tried with :wq and :q! I thought you were only trying with :w and :q , I'm sorry for that.

                   

                  If this is only happening with that file you can try with these lines:

                  root@edison:~# echo src/gz all http://repo.opkg.net/edison/repo/all  > /etc/opkg/base-feeds.conf
                  root@edison:~# echo src/gz edison http://repo.opkg.net/edison/repo/allsrc/gz  >> /etc/opkg/base-feeds.conf
                  root@edison:~# echo src/gz core2-32 http://repo.opkg.net/edison/repo/allsrc/gz >> /etc/opkg/base-feeds.conf
                  

                   

                  -CMata

                  1 of 1 people found this helpful
                  • 6. Re: Vi cannot edit opkg base-feeds?
                    Elspin

                    I think I've found my problem... I'm getting this as a response

                     

                    root@Quincy:~# echo src/gz all http://repo.opkg.net/edison/repo/all > /etc/opkg/base-feeds.conf

                    sh: write error: No space left on device

                     

                    so I guess something running on it has completely destroyed the space. I'm probably going to try and do a factory restore-ish situation on it once I get home, because a friend was fiddling with it to see what they could get to work and something had an issue clearly. Deleted a few random directories and it worked fine.