3 Replies Latest reply on Apr 27, 2015 11:41 AM by DiegoV_Intel

    Galileo Gen 2 UART

    Wunderbred

      Hello,

       

      I have been, recently got a Galileo Gen 2 board. I got the full sd card image and uploaded a sketch to allow Ethernet and and ssh'ed into the os, I then I uploaded a blink sketch. after word I put it back into the static bag set it aside. A couple days ago I got a bit of time and tried to upload a sketch. At first it registered fine, it was visible in device manager on com 8. I followed the procedure to build and install Debian linux. At first everything worked fine but all of a sudden it disappeared from device manager and I couldn't upload a sketch. I unpluged everything including the SD card then pluged power back in let it boot then the USB cable and got a message stating the device has malfunctioned and can't be recognized. I did some googling and found Intel® Galileo Boards and Kits — Recovery Mode . I don't know much about serial communication, I don't have and FTDI usb cable but I do have a USB to 9-pin serial adapter a DB-9 plug and a 6-pin female header, could I use that with and external 3.3v source and a common ground, or do the two devices work a little differently.

        • 1. Re: Galileo Gen 2 UART
          Wunderbred

          Ok, I did a bit more research and it looks as though it should work as long as I use an external 3.3v source. I now have another question. Will and arduino uno put out enough current from its 3.3v line to power the gelileo or should I make a circuit with an LM317?

          • 2. Re: Galileo Gen 2 UART
            Wunderbred

            This morning I decided I was going to get my laptop and try hooking my Galileo up to it and see if it was just an issue with my Windows 8 system (though it was working before). When I plug in my power supply into the Galileo it doesn't power up, it was working yesterday. When I plug it into USB it will power-up. I was excited about the Galileo but from what I am reading and my experiences its not good. I exercise safety when working with it too, I always wear a ESD wrist strap and never set it down on anything but an ESD mat. I have checked my power supply and it reads 12v, when I check the voltage on the +ve/-ve posts when connected to the board it reads between 20mV-200mV.

             

            The box says what will you make, so far all I have made was 3 posts to an Intel forum.

            • 3. Re: Galileo Gen 2 UART
              DiegoV_Intel

              Hi Wunderbred,

               

              I have read your other thread: Technical Questions and we have received your warranty ticket as well.

               

              Regarding your question about the LM317, I think it has an output current up to 1.5A. The power supply unit I use for the Galileo Gen2 has also an output current of 1.5A so I think you can use the LM317 to power the board.

               

              About the issue with your board, as I said, we received your warranty ticket so you will receive support in it.

               

              Regards,

              Diego.