2 Replies Latest reply on Apr 25, 2015 5:58 AM by nenieorg

    No BIOS (only PXE) display on NUC5i5RYB with Dell P2415Q 4K

    nenieorg

      Hi there,

       

      I've got a brand new NUC5i5RYH and I'm stuck at trying to get to the BIOS to enable it to boot something.

       

      I've seen some others have similar problems but I thought I'll report my experience to add some data:

       

      On the Display Port:

       

      - using Dell's DP-mDP cable that came with the monitor

      - nothing displayed

      - the NUC does talk to the monitor enough for the monitor to react by going to sleep when the NUC is switched on

       

      On the HDMI Port:

       

      - using High Speed HDMI/HDMI cable full size connectors + HDMI adapter micro/mini/full Y adapter

      - the PXE network boot console is shown in 640x480 about 2-3s after boot

      - when pressing F2 after the keyboard numlock led switches on, I get no display (presumably being in the BIOS in 4k)

       

      The funny thing is that I've seen the BIOS once. Problem is it didn't last and I can't reproduce it now as I don't know what exact sequence worked! I think it was on HDMI but not 100% sure. It was displayed in 4K -- tiny box (1024x768?) in the middle of the screen. I have no mouse at the moment and it apparently locked up before I could figure out keyboard navigation, and I crtl-alt-del and never saw it again.

       

      I have not tried other monitors as the only one I have is an ancient DVI/VGA one, and I've got no DVI/HDMI solution.

       

      I've tried to boot an Ubuntu USB install stick regardless, but that blinks the LED on the stick and gets stuck. (No legacy on USB? Video stuck as well?)

       

      Things connected:

       

      - 1x 4GB KVR16LS11 (on approved list)

      - USB keyboard

       

      BIOS:

       

      - I've updated the BIOS using the USB stick + jumper trick yesterday which as far as I know worked (it blinked as speced and I think I saw the number that one time I saw the BIOS).

       

      Questions:

       

      - is there a way to bypass the BIOS or to access it using the network? (trying to boot an Ubuntu USB install stick gets no display as well)

      - I guess I could try to set up a PXE server for a diskless boot of an install but that seems a hassle, has someone tried that?

       

      On the other threads, some people seems to have solved similar issues by trying other video cables. I've got some ordered, but I'm not impressed by Intel staffer replies like "we do not support adapters" or "try another cable". I'm just guessing, but what it looks like so far is fragile timing issue or something like that (hence my seeing the BIOS once?), maybe a combination of RAM and video link timing, where the hardware is too sensitive to a slightly non-optimal link. Instead of saying it's the users' problem to find perfect lab-condition hardware, why not put some engineers in a room with a box of adapters and cheap cables and get them to try to make the thing more robust?

       

      If the new cables don't work, I need to know whether this could be a dud unit or it is a design fault (in the former case I need a replacement, in the latter case a refund and buy someone else's hardware).

        • 1. Re: No BIOS (only PXE) display on NUC5i5RYB with Dell P2415Q 4K
          hansb_intel

          Hi,

          My Suggestion would be to wait for the new cables or try another monitor, just to see if the system will post and let you install the operating system, After installing the OS, try to us the 4K monitor.

          • 2. Re: No BIOS (only PXE) display on NUC5i5RYB with Dell P2415Q 4K
            nenieorg

            So here's an update with the new cable, tl;dr: it works. DisplayPort at 60Hz too!

             

            HDMI:

             

            The new cable is a cheap mini-HDMI to HDMI, relatively short (75cm).

             

            - new HDMI cable to old 1280x800 monitor via DVI adapter: works all the time

            - new HDMI to 4K monitor: works 2/3 of boot cycles, when failing "bad timing" error on the monitor, but at least good enough to get into the BIOS

            - after Ubuntu 15.04 install HDMI to 4K seems stable when in the OS (but I've not tested it very long)

             

            DisplayPort:

             

            - The BIOS was 0246 so I updated to 0247. DisplayPort still no show before OS install

            - Now the surprise: after OS install not only does DP work with the stock Dell cable, but it also works during the boot (splash screen and BIOS), including after a power cycle! That's weird, as I would have thought the state of the graphics/BIOS should not persist across power cycles. It's good here, but could be bad if the OS takes it into a bad state.

            - The DisplayPort is running 4K at 60Hz (vs 30Hz for HDMI) on Ubuntu 15.04

             

            So on the DisplayPort side it looks like a software problem in the BIOS. Harder to say whether HDMI could be less sensitive to cables with better software or we're having hardware issues.

             

            Tips:

             

            - it should be possible to enable Legacy boot by typing keyboard navigation blind. Intel could help by having command line style magics in the search box the cursor starts in after F2.

            - the F10 boot selection menu is in 800x600 which may work in some circumstances where full screen doesn't?