10 Replies Latest reply on Oct 26, 2009 8:15 AM by Yotta

    Sata RAID drive misdetecting

    Yotta

      Have stumbled across a problem that has me dumbfounded, just trying my luck to see if anyone knows what the issue is and hopefully how to fix it. It seems similar to the issues with the Matrix manager marking drives as failed that haven't, but at the BIOS level.

       

      I have a Gigabyte GA-965P-D6Q motherboard, which has the intel P965 express chipset and the intel ICH8R SATA/RAID controller. I am trying to run a 4 disk RAID5 setup (which should be within the capabilities of the ICH8R). I am using Seagate barracuda 320Gb drives, of which I have two older 8Mb cache drives and two brand new 16Mb cache ones (research suggests cache has no effect on RAID, but have tried with both drive caching enabled and disabled
      )

       

      The first time I booted with clean drives, everything worked fine and I installed Vista x64 and all my programs, numerous reboots etc. The next day when I booted the 4th drive (one of the brand new ones) wasn't detected cleanly by the RAID BIOS halting the system at that point. Assuming that the drive was a dud I took it back and exchanged for a new one. Put the new one in, everything worked fine, it rebuilt the array, but on the next reboot the 4th drive was not detected. I rearranged the drives and booted the 4th one as a stand alone disk, tested it (no errors) and reformatted it, added it to the array and everything worked fine, it rebuilt the array. On the next reboot it was misdetected. I have tried changing around which port the 4th drive is in, which has had no effect.

       

      To clarify what I mean by misdetected, the RAID BIOS was "SERIAL ATA AHCI BIOS version iSRC 1.07" It detects that there are 6 ports and 4 drives in the first line, but when it lists the ports and drives it finds the first three, but on  the fourth it halts without writing anything. I have left it in this state for over an hour to see if it was just delayed but nothing changed. I have updated the BIOS so I now have "SERIAL ATA AHCI BIOS version iSRC 1.20E" but it has the exact same problem. I didn't install the Matrix manager until I'd reformatted the replacement drive a couple of times, so I don't think its related to that.

       

      I just don't get how when I first installed I got a good 12hrs and numerous reboots before I struck the problem, and ever since I can get a single boot from a clean drive but that is all. Is there any way to check whether a drive is being flagged as 'bad'? While my system is working fine in degraded mode I would really like to get that last drive working normally so I get my parity back before one of my other drives decides its had enough... Any suggestions would be appreciated.

        • 1. Re: Sata RAID drive misdetecting
          PeterUK

          Matrix manager not only installs Matrix manager but also the driver used to setup RAID with the OS.


          There is nothing wrong with Matrix manager 8.9 the 8.9 driver is the problem.


          If you used Vista drivers to install the OS its likely using an old driver so you should update it to 8.8.


          If your sure its at the BIOS level do the following:

          Do not overclock try a stock.

          Swap power cables and SATA cables.

          • 2. Re: Sata RAID drive misdetecting
            Yotta

            And so the plot thickens...

             

            In reply to Peter, I haven't ever overclocked this computer, and I have tried swapping power cables, changed the SATA cables with new ones in case one was broken, have swapped around which ports the drives were in, all to no effect.

             

            As to the thickening plot, I have narrowed down the causes. Not being able to get that drive back, I un-RAIDed all the drives, changed the order they were plugged in and rebuilt the array. Absolutely no problems again with installing Vista, than I  installed WinXP. Next boot the fourth drive (different physical drive to last time) was misdetected, so I'd guess it's something about the WinXP 32bit drivers... I completed the install on 3 disks, updated to the latest matrix manager, booted the fourth drive stand alone and formatted it, reintroduced it to the array, it worked fine, rebuilt the array in WinXP, next boot it was gone again. Perhaps I'm doing something shifty in having multiple partitions on a RAID array, or having a 32bit and a 64bit OS on the same array

             

            If there's any Intel techs that have seen the source code of the SATA BIOS, the system is halting on a 23, so if you know what stage that is would be another clue....

            • 3. Re: Sata RAID drive misdetecting
              PeterUK

              Is the Firmware the same as the other drive (just the two that are the same)?

               

              Some boards have a BIOS setting that do a 'delayed HDD spin up' try setting this to 3.

              • 4. Re: Sata RAID drive misdetecting
                Yotta

                The drives are quite different, the first one was a new, slimmer design with 16Mb cache, while the current one is an older, chunkier 8Mb cache (ST3320620AS compared to ST3320418AS model  numbers, 3.AAK compared to CC35 firmware numbers) Incidently I did check up on whether there is any firmware upgrades for the drives, but there weren't.

                 

                I haven't seen any options for delayed HDD spin up, will have a closer inspection next time I reboot, but I would expect that to affect the drive on every boot, rather then letting it through once, but halting it every boot thereafter...

                • 5. Re: Sata RAID drive misdetecting
                  KenChicago

                  I, too, am seeing this now, somewhat out of the blue.  I am wondering, Yotta, if you figured out what this was caused by, or better yet, how to fix it?  I have a newer P55 board, but same SATA BIOS: "SERIAL ATA AHCI BIOS version iSRC 1.20E" as you quoted earlier.  The system had been booting fine for a month, then all of a sudden it now hangs when detecting my WD SATA II 640GB drive.  I have tried this drive on other SATA II controllers without issue.  The drive seems perfectly fine.  But as soon as I plug it into this controller it hangs.  I see a number 23 off to the upper right of the screen, don't know if that means anything.  Very frustrating because I don't know if it is something I can fix,or if it is an issue with the board/controller, etc., and obviously unable to boot to OS.  If anyone has any ideas, I am all ears.  I've spent hours on this already.

                  • 6. Re: Sata RAID drive misdetecting
                    Yotta

                    Unfortunately I've had no luck finding a fix for this problem, nor finding anyone that seems to have even a clue what could be causing it. I've guessing it is just some random error with the ICH8R chip on my board, (completely speculating) possibly linked to how it is restricted to 4 disks in  RAID5, that, because  very few people would use RAID5 in a personal computer, has flown under the radar.

                     

                    At this point I've pretty much given up on running RAID5 on this system, I'll probably just drop back to a split of RAID1 (for data I don't want to loose) and RAID0 (for data I want a performance increase with)

                    • 7. Re: Sata RAID drive misdetecting
                      KenChicago

                      That's interesting because I'm not running with RAID, just AHCI and just 1 drive, but same issue you have otherwise.  I will post if I find anything out there.

                      • 8. Re: Sata RAID drive misdetecting
                        KenChicago

                        This may or may not help you, and perhaps you've already seen this.  But I came across this thread and it mentioned some different things for a similar issue that seemed to sync up with your trouble - perhaps related to the RAID array's meta data.  I ended up fixing my issue with Diskpart and running the Clean action.  This of course cleared my drive / partition information, but was reinstalling Windows anyway.  Anyhow, didn't want to not share this, in case it can help you too.  Maybe the 2 different OS's you're using are writing conflicting information to the drive(s) that the array controller doesn't like.  Just a theory from a non-RAID expert.  Good luck.

                        • 9. Re: Sata RAID drive misdetecting
                          Uraki

                          I think I may have found what is happening.

                           

                          I have a new Gigabyte GA-P55-UD2 motherboard with the 8.9.0.1023 Matrix Raid and found out that when I set up a RAID5 with 4 drives & installed Win 7 RC x64, everything worked fine until I powered off the machine.

                           

                          The Matrix Raid console was reporting SMART errors (but doesn't show you what they are...grrr) before the power off.

                           

                          When you power off/on, at least one drive drops out and then shortly afterwards, all drive drop out and BOOM!  your raid is gone along with your data!

                           

                          I did this 3 times(!) to prove to myself it was repeatable.

                           

                          Then I tried using the latest Ubuntu 9.10 beta and it all became clear!

                           

                          When Ubuntu boots off the LiveCD, it has some sort of SMART monitoring that tells you that ALL of your drives are facing "imminent failure"!

                           

                          The Ubuntu SMART tool lets you see the detail info that is causing the alarm....and in my case, it's the spin up time.

                           

                          The threshold on my drives is 11 seconds and due to the staggered spin up, the first drive is like 21 seconds, the second drive is like 32 seconds, etc.

                           

                          So, due to the staggered spin up, all the drives exceed the SMART spin up time threshold....and if that threshold is exceeded, the drive is flagged as "pre-failure" so SMART reports the drive is dying and then I suspect the Matrix Raid drivers dutifully start dropping the drives.

                           

                          So, I suspect that if I used "raid edition" drives, this problem wouldn't occur.

                           

                          But the problem remains....how to keep the spin up time threshold from being exceeded on "regular" drives used in an Intel Matrix Raid.

                           

                          I can't seem to clear the "failing" status on the drives now (Ubuntu reports them as "imminent failure") and I've found no way to overwrite/change the spinup threshold on the drives themselves.

                           

                          Hope this helps solve the mystery of what is going on.

                          • 10. Re: Sata RAID drive misdetecting
                            Yotta

                            Still no real ideas as to whats happening but thought I'd update... I gave up on the RAID5 and dropped back to two seperate RAID1 arrays (lose 1/3 data storage, but regain redundancy). So far the problem hasn't resurfaced with that setup, though did loose a single drive at one point after a (one off, program related) system crash, but that might have been it didn't complete both writes before I rebooted so the drives were out of sync. Have noticed one of the old drives is invoking ERC quite frequently and probably needs replacing, but to date the RAID manager hasn't been too bothered by it. (NB different drives were dropping out of the RAID5 array) I think I'm just going to rule it as one of the quirks of computers, with the speculation that the WinXP and Vista drivers were writing conflicting information to meta data.