1 Reply Latest reply on Apr 20, 2015 8:25 AM by KurtE

    Drivers not successfully installed for Edison module but another module works fine

    helpme46

      I happen to have 2 Edison modules. Driver installation was smooth on one of the modules. I could see 4 entries on the device manager;

      - Intel Edison USB Composite Device

      - Intel Edison Virtual Com Port

      -Intel Serial Port

      -Intel Edison USB RNDIS device

       

      On the other module, driver installation failed. I could only see "USB Serial port" driver appearing on the device manager. I am not able to flash in new image into this Edison module . No extra drive appeared on my Windows Explorer.

       

      Could it be that the Intel Edison module is faulty? Otherwise, why is it one module works and the other fail? I am using the same laptop and breakout board for both Edison modules.

        • 1. Re: Drivers not successfully installed for Edison module but another module works fine
          KurtE

          Might help to see more information.  If it were me, with the one that is not working fully for you.

          1) Connect a USB cable to the debug port.  Start up PuTTY and choose the Serial port associated with the debug port and set the baud rate to 115200 and connect

          2) Plug in the other USB port.  What shows up in the PuTTY window?

           

          If nothing shows up in terminal window, then my guess is the Edison module is toast (I have one that is in that state that was working earlier).

           

          If you do receive a bunch of debug stuff, does it finally come up to a login prompt?  If so it is at least somewhat working.  You might try to login to root and see if you can set stuff up.

           

          If it stops at some point without getting to a login prompt, would probably be good to show the details on this thread.  On Friday I receive a new board from NewEgg, I tried using the all in one install, which failed on the firmware update.  I tried a few things and was in the state here, where the board would not boot enough to allow a flashall to work.  I resolved it for my board, by using flashall --recovery on my linux machine, after I downloaded, built and installed the necessary programs.  Hopefully you will not need to resort to this...