2 Replies Latest reply on Apr 24, 2015 5:22 PM by CMata_Intel

    Error sketch downloadGalileo

    nepash

      Hello,

       

      I have been having this problem for nearly months now and I could not solve it. I am using arduino 1.6.0( but also tried on 1.5.3) and Macbook with OS X Yosemite.

      I know my port number is right which is:cu.usbmodemfa131 and board is intel galileo (gen 1). But I am having same error over and over again. I already tried looking different forum and try what they have said but none of them worked so far. I have posted error below. Can you guys suggest what should I do?

       

       

      Sketch uses 54,682 bytes (0%) of program storage space. Maximum is 10,000,000 bytes.

      starting download script

      #!/bin/sh

      Args to shell: /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/x86/bin /var/folders/_p/vywgz5_54mndf_d7nq9c_wdh0000gp/T/build1749523739727379765.tmp/sketch_apr16c.cpp.elf /dev/cu.usbmodemfa131

       

       

      Serial Port PORT (note: should be /dev/cu.xxxxxx for OSX)

      # clupload script to invoke lsz

      Using tty Port /dev/cu.usbmodemfa131

      # Copyright (C) 2014 Intel Corporation

      #

      Sending Command String to move to download if not already in download mode

      # This library is free software; you can redistribute it and/or

      # modify it under the terms of the GNU Lesser General Public

      # License as published by the Free Software Foundation; either

      # version 2.1 of the License, or (at your option) any later version.

      #

      # This library is distributed in the hope that it will be useful,

      # but WITHOUT ANY WARRANTY; without even the implied warranty of

      # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU

      # Lesser General Public License for more details.

      #

      # You should have received a copy of the GNU Lesser General Public

      # License along with this library; if not, write to the Free Software

      # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301  USA

      #

      echo "starting download script"

      echo "Args to shell:" $*

      #

      # ARG 1: Path to lsz executable.

      # ARG 2: Elf File to download

      # ARG 3: TTY port to use.

      #

      #path may contain \ need to change all to /

      path_to_exe=$1

      fixed_path=${path_to_exe//\\/\/}

      #

      tty_port_id=$3

      echo "Serial Port PORT" $com_port_id "(note: should be /dev/cu.xxxxxx for OSX)"

      echo "Using tty Port" $tty_port_id

      #

      echo "Sending Command String to move to download if not already in download mode"

      echo "~sketch downloadGalileo" > $tty_port_id