2 Replies Latest reply on Apr 23, 2015 9:30 AM by Sneaker15

    Issues on DH87RL with MSATA drive Crucial M500

    Sneaker15

      Hi all,

      I have a mSATA drive on which my virtual machines are running. When under load I regularly receive errors from the drive like the follows:

       

      [Fr Apr 10 10:01:20 2015] ata6.00: exception Emask 0x50 SAct 0x20000 SErr 0x4890800 action 0xe frozen

      [Fr Apr 10 10:01:20 2015] ata6.00: irq_stat 0x08400040, interface fatal error, connection status changed

      [Fr Apr 10 10:01:20 2015] ata6: SError: { HostInt PHYRdyChg 10B8B LinkSeq DevExch }

      [Fr Apr 10 10:01:20 2015] ata6.00: failed command: WRITE FPDMA QUEUED

      [Fr Apr 10 10:01:20 2015] ata6.00: cmd 61/40:88:90:29:e9/05:00:09:00:00/40 tag 17 ncq 688128 out

                                         res 40/00:8c:90:29:e9/00:00:09:00:00/40 Emask 0x50 (ATA bus error)

      [Fr Apr 10 10:01:20 2015] ata6.00: status: { DRDY }

      [Fr Apr 10 10:01:20 2015] ata6: hard resetting link

      [Fr Apr 10 10:01:21 2015] ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 310)

      [Fr Apr 10 10:01:21 2015] ata6.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded

      [Fr Apr 10 10:01:21 2015] ata6.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out

      [Fr Apr 10 10:01:21 2015] ata6.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out

      [Fr Apr 10 10:01:21 2015] ata6.00: supports DRM functions and may not be fully accessible

      [Fr Apr 10 10:01:21 2015] ata6.00: disabling queued TRIM support

      [Fr Apr 10 10:01:21 2015] ata6.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded

      [Fr Apr 10 10:01:21 2015] ata6.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out

      [Fr Apr 10 10:01:21 2015] ata6.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out

      [Fr Apr 10 10:01:21 2015] ata6.00: supports DRM functions and may not be fully accessible

      [Fr Apr 10 10:01:21 2015] ata6.00: disabling queued TRIM support

      [Fr Apr 10 10:01:21 2015] ata6.00: configured for UDMA/33

      [Fr Apr 10 10:01:21 2015] ata6: EH complete

      I found various threads but most of them indicated a bad SATA cable to be the issue. Since this is a mSATA drive which is directly attached to the mainboard there's no cable involved.

      Then I found a thread on this forum indicating a voltage problem. Can anyone confirm compatibility issues with this mainboard+msata combination?

      Is there a way to override and manually adjust the voltage in the BIOS to provide the msata drive with the appropriate voltage?