10 Replies Latest reply on Apr 27, 2015 4:08 PM by hansb_intel

    Wake from S4/5 from USB not working

    Hobentus

      I have NUC5i3RYK. I have enabled this option in BIOS, but cannot get any USB device I have tried to wake the NUC from S4 or S5. I have tried Logitech K830 wireless keyboard, a Gigabyte wireless keyboard and mouse, and an old MS wired mouse. No action at all. I have discussed this bug over on the Kodi forum and had it confirmed by another user as well.

        • 1. Re: Wake from S4/5 from USB not working
          sylvia_intel

          Hello Hobentus, thanks for joining the Intel Community.

           

          Would you please let me know the following information?

           

          Which is the current BIOS version?

          Which operating system are you using?

           

          I was able to test this NUC in our lab and I did not experience this behavior. I was using a Microsoft wireless keyboard and mouse.

          These are the settings I had in BIOS

          20150414_124228_3.jpg

          • 2. Re: Wake from S4/5 from USB not working
            Hobentus

            EDITED:

            Thank you for considering my problem.

             

            All the details:

            NUC5i3RYK (with 2x4GB Kingston KVR16LS11/4 SODIMM; Samsung SSD 850 EVO 120GB M.2)

            BIOS: Two different BIOS’s – 1st - RY0246.BIO, 2nd - RY1944.bio

            OS: Win 8.1 64 bit.

            Keyboard: Logitech K830.

             

            Settings in BIOS:

            1. All settings identical to your's above - Can get USB keyboard wake from S4 (Hibernate), cannot get wake from S5 (Off).

            2. All settings the same as your's above except 'Wake on LAN from S4/S5' unchecked: Cannot get any 'Wake on USB from S5' or wake from S4.

             

            Why is there an interaction between the Wake from LAN settings and the USB action?

            I had initially disabled Wake from LAN because the NUC keeps doing exactly that; every time another PC on the network looks at the network shares, the NUC wakes up and boots, which I don't want as this is a HTPC  At the moment, I can't recomend this as a HTPC because of these wierd power switching issues.

             

            Can you please test your setup in the Lab with 'Wake on LAN from S4/S5' disabled, and report what happens? Testing needs to include both the off condition and the hibernate condition. Thank you in advance for any response to this as it would be most appreciated. If I can't get this working I will need to return this device as faulty.

             

            warm regards,

            Hobentus

            • 3. Re: Wake from S4/5 from USB not working
              Hobentus

              Edited post above after some detailed performance testing with the BIOS settings.

              • 4. Re: Wake from S4/5 from USB not working
                sylvia_intel

                Hobentus, I’m going to set up the lab ASAP in order to let you know the results.

                 

                I’ll keep you posted.

                • 5. Re: Wake from S4/5 from USB not working
                  Hobentus

                  Fantastic. Much appreciated.

                  • 6. Re: Wake from S4/5 from USB not working
                    sylvia_intel

                    Hobentus,


                    The Bluetooth Adapter is part of the WiFi adapter. If Wake on Lan is shut off that turns off that feature on the entire card which would include the Bluetooth adapter. So it is behaving as it should.

                    So if you want to be able to wake up your system with a Bluetooth connected Keyboard, it will be necessary to leave Wake On Lan enabled.

                    • 7. Re: Wake from S4/5 from USB not working
                      Hobentus

                      Hi Sylvia,

                       

                      My keyboard is 2.4 GHz Wireless with its own receiver, which is plugged into one of the NUC’s USB3 ports. It doesn’t use the NUC on-board Bluetooth or Wi-Fi at all. This setup should work just fine with Bluetooth and Wi-Fi disabled.

                       

                      Keyboard is Logitech K830 - http://www.logitech.com/en-au/product/living-room-keyboard-k830

                       

                      I have also tried to wake the NUC from S4 using a wired Microsoft mouse, and wired Microsoft keyboard with the Wake on LAN disabled, and it doesn’t wake the NUC.

                       

                      So, in summary:

                      USB Wake from S5 – no action at all regardless of Wake on LAN settings, or USB Wake settings.

                      USB Wake from S4 – works when Wake on LAN is enabled.

                      • 8. Re: Wake from S4/5 from USB not working
                        sylvia_intel

                        Hobentus,

                        I just tested a NUC5i5RYH with the “Wake on LAN” option disabled in BIOS and I was able to wake the system using a wired and a wireless mouse and keyboard. (2 different tests) 

                         

                        The current BIOS version is 0137. Since this is a new installation I haven’t installed all the drivers. At this point the NUC only has the chipset and the graphics drivers.

                        • 9. Re: Wake from S4/5 from USB not working
                          Hobentus

                          Thanks Sylvia,

                          I'm using your latest BIOS from April 15th - 0247. No change here on my end to NUC responses.

                           

                          I tried to flash the old BIOS you are using from January - 0137, but the updater failed, presumably because its an older BIOS (...any suggestions on how to flash the older BIOS?).

                          Can you try 0247?

                          • 10. Re: Wake from S4/5 from USB not working
                            hansb_intel

                            Hi,

                             

                            I will try updating the BIOS to 0247, It is no likely that you can roll back to 0137, But I'll try this as well.