5 Replies Latest reply on Apr 20, 2015 1:18 PM by JPMontero_Intel

    hi everyone

    neo-v

      I'm making a flash image for my galileo board,

      but i have some problems .when i run Makefile.sh it can't find openssl, how do i make a proper configuratino .

      thanks

       

      搜狗截图20150404163345.png

        • 1. Re: hi everyone
          JPMontero_Intel

          Hi neo-v,        

           

          Which BSP version are you using to build the image? Also which openssl version do you have installed? In case you don’t know, type in the terminal openssl version this will display the version installed. Finally did you follow the steps indicated in CryptoPkg/Library/OpensslLib/Patch-HOWTO.txt? This file is created into your EDKII directory when you run the svn_setup script. In case you haven’t applied this patch, follow the steps and let me know if the error persists.

           

          Regards,
          JPMontero_Intel

          • 2. Re: hi everyone
            neo-v

            i've found i did not install libssl-dev,but there is a another problem,when i tried to run Makefile.it means no rules to create....

            please help me what's wrong with it?

            thank you .

            搜狗截图20150407122736.png

            • 3. Re: hi everyone
              MarkHaysHarris777

              You must be kidding, right?

               

              Build problems are *very* difficult to track down and fix OFTEN when the help is sitting right there with their own hands on the driver's wheel... 

               

              Never, and I repeat, never post a picture of a 'build error' and say, PLEASE SoMEone ANYONE just HELP ME!...

               

              ... because most people will ignore you and the rest will just laugh.

               

              Seriously, and I mean this kindly...  find someone locally who understands the build process and have them sit down with you and take a look...

               

              Good luck.

              marcus

               

              • 4. Re: hi everyone
                neo-v

                thanks for your reply.I've  figured  it out yet.

                if someone has same issue and conquer it then i can save a lot of time.

                • 5. Re: hi everyone
                  JPMontero_Intel

                  neo-v -  We should continue this issue in https://communities.intel.com/thread/63246, to avoid having multiple posts for the same problem.

                   

                  Regards,
                  JPMontero_Intel