8 Replies Latest reply on Sep 2, 2009 3:59 PM by m610

    Recovering from a RAID failure

    m610

      I've been using the Matrix RAID (ICH7R) on my D955XBK board for a couple of years, using two 2-drive RAID1 arrays.  A few days ago when I booted the system and one drive in the first (system) array had failed.  I backed up nearly everything.  The next day, on boot, the second drive failed.  I hadn't had time to replace the first drive, and I'm wondering if it would have even been possible with the second drive failing so soon.

       

      I replaced the drives and reinstalled the OS, but, I can't get XP to recognize my second array.  The BIOS sees is.  Device Manager sees it and gets the array name right.  Disk Manager sees it and gets the name, formatted capacity, and disk usage right, but it only gives me the option to delete the partition.  It seems that I only need to give it a drive letter.

       

      I know this is not exactly a desktop board question, but maybe someone here knows.

       

      Thanks.

        • 1. Re: Recovering from a RAID failure
          m610

          After more reading, I'm wondering is a recent update of isstor.dll might be a factor in the back-toback failure of my two drives.  By the way, these are Seagate 7200 drives, 500 GB.

          • 2. Re: Recovering from a RAID failure
            m610

            TestDisk does not find any errors.

            • 3. Re: Recovering from a RAID failure
              PeterUK

              Are you using Matrix Storage Manager 8.9?


              Download Matrix Storage Manager 8.8 and see what Matrix Storage Manager see your second array as and maybe run a Volume Verification and Repair.


              As long as you reinstalled XP with RAID enabled and with RAID drivers your second array should be as you left it.


              When you replaced the system array and reinstalled XP you did install on the right array?


              To recover files try this Freeware Raid Reader

              http://www.diskinternals.com/raid-to-raid/

              as the partition seems ok file recovery tools should work.

              http://www.pcinspector.de/Sites/file_recovery/info.htm?language=1

              • 4. Re: Recovering from a RAID failure
                m610

                Thanks for the suggestions.

                 

                I did install the the OS on correct array.

                 

                I'll check out those links.

                 

                I think I have hit on a solution and am trying it now.  I had Norton Utilities on the PC and thought it was really odd that with new system drives and no OS that GoBack would pop up, then fail.  I wondered where it was hiding and it must have been in my second array.  Anyway, the Symantec program that removes it is working now, and is taking a while.  It is supposed to restore the MBA, or whatever it is called.   Hopefully that will do the job.

                • 5. Re: Recovering from a RAID failure
                  m610

                  Fixed it.  Took some time, and searching.

                   

                  Turns out that Norton GoBack was the culprit.  I had it installed before the failure and it seems that it modifies the MBA database, or whatever it is called.  Symantec has a program to take care of this.  You download the ISO image file, copy it to a CD, reboot from the CD, select opton 1, then wait for about an hour and a half, and finally reboot, and now everything is good.  Well, except for the two drives that failed, and for these I am beginning to suspect a driver problem (iastor) that causes random SMART errors.

                  • 6. Re: Recovering from a RAID failure
                    m610

                    Update and more details.

                     

                    Both drives that (supposedly) failed were Seagates.

                    The Windows version of Seatools that came with the new drives I bought  failed to run. "Counter less than zero error", or something like that.

                    The Windows version I downloaded today started, and scanned the drives, but would not run any test on any drive.

                    The DOS version I downloaded today is working.

                    The two drives that failed on me last week, within a day of each other, were the two drives in my system RAID1 array. Odd that they failed one after the other.

                    My motherboard (Intel D955XBK) had reported that both drives had failed. These were running on the ICH7R controller.

                    DOS Seatools says one is good and no SMART events had occurred.  It also passed the short test.

                     

                    DOS Seatools says the other drive has SMART was tripped. When running the basic test it warned me that the drive had experienced temperatures over 70C. ???? It was mounted right next to the other one. Anyway, the short test failed and the long test is now running.

                    Both drives are ST3500641AS, firmware versions are 3.AAB .

                    I don't know why my MB reported SMART errors on both drives. I'm still hoping I can recover data from them. I had backed up most, but not all, of my files.

                     

                    Message was edited by: m610

                    • 7. Re: Recovering from a RAID failure
                      m610

                      The second drive quit working before the long test could finish.  It made it to 83%.

                       

                      I tried putting the first drive back in, seeing as it passed and had no SMART errors.  If I could get it to boot I could get my files off.  Unfortunately, the BIOS said it was off-line.  I need to find another way to get my files off.  The links offered above look pormising, although it looks like I'll need to $250 software for this.

                       

                      Message was edited by: m610 (typos)

                      • 8. Re: Recovering from a RAID failure
                        m610

                        Final report.

                         

                        Here's what I did, and to spoil the ending, I got my files and everything is running.

                         

                        After the SeaTools tests I put them back into the system to verify that the system could not use them.  I tried, one, both, then switched them (swapped cables).  The BIOS reported one had failed and the other was offline, or not working, depending which I hooked up with which cable.  Anyway, it was clear I wouldn't be getting the system to boot this way.  I thought about going into the RAID BIOS utility and switching them back to solo drives but was concerned about data loss.

                         

                        To back up a bit, I've now replaced my 2 x 500 GB RAID1 array that held my OS and other files with 2 x 1TB drives, installed the OS and a few apps, and that's working.

                         

                        I found a file DIY recovery tool at Seagate and was all ready to try out the demo version, just to see if I could get my files back.  I installed the still-good drive in an external SATA bay and booted the system, and it booted to THAT drive!  That was probably the best luck I could have had, because now I could just copy my files to another drive.  I guess the boot order in my BIOS had reverted to using the Promise SATA card.  I backed up my files asap, plus I downloaded a program that would backup my Thunderbird email and FireFox settings and backed them up.  I shut down, removed the former RAID1 C: drive, rebooted, and the new system came up.  I then installed Firefox, then restored my old settings.  I then repeated the process for Thunderbird.  Done.  Now I can finally put the top back on the case, finish installing apps, and get back to work.

                         

                        I was surprised that the system would boot on this drive and even more surprised that everything was intact.  RAID1 is mirroring, so there should be duplicates of the files on each drive, but I still expected issues with the file names, partitions, etc.