7 Replies Latest reply on Apr 13, 2015 6:33 PM by vinceskahan

    D54250WYKH loses WD Red disk continually

    vinceskahan

      My i5 is continually losing the WD Red 1TB spinning disk, although the system boots and runs fine off the Crucial M550 256GB mSATA SSD under centos-7.1

       

      Question I have, given other folks complaining about their NUCs similarly having problems with the spinning disk, is:

      • is the disk bad
      • is the nuc bad
      • is the bios bad
      • how can I tell ?

       

      The system is rock solid running off the SSD, it's just the spinning disk having problems.   I had some periodic issues running ESXi in the past where the laptop disk would throw errors and my datastores would disappear (this was before I added the mSATA SSD) where a complete power removal, plug it back in, and power it up seemed to do magic.

       

      Some error messages from syslog are online here if you want to take a look.  At this point, even powering the system down, removing power from the NUC for a while, and plugging it back in and restarting does not work.  The disk gets tossed at centos bootup.

       

      • Bios is DMI: /D54250WYK, BIOS WYLPT10H.86A.0035.2015.0126.1814 01/26/2015
      • os is centos-7.1
      • kernel is centos-7.1 Linux version 3.10.0-229.1.2.el7.x86_64
      • Command line: BOOT_IMAGE=/vmlinuz-3.10.0-229.1.2.el7.x86_64 root=/dev/mapper/centos-root ro rd.lvm.lv=centos/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=centos/root crashkernel=auto vconsole.keymap=us rhgb quiet LANG=en_US.UTF-8

       

      Most recent powerup snippet ends with:

      [    5.073846] ata1.00: status: { DRDY }

      [    5.075329] ata1: hard resetting link

      [    5.379660] ata1: SATA link down (SStatus 0 SControl 310)

      [   10.377920] ata1: hard resetting link

      [   10.682757] ata1: SATA link down (SStatus 0 SControl 310)

      [   15.680943] ata1: hard resetting link

      [   15.985837] ata1: SATA link down (SStatus 0 SControl 310)

      [   15.985842] ata1.00: disabled

      [   15.985850] sd 0:0:0:0: [sda]

      [   15.985852] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE

      [   15.985853] sd 0:0:0:0: [sda]

      [   15.985855] Sense Key : Aborted Command [current] [descriptor]

      [   15.985857] Descriptor sense data with sense descriptors (in hex):

      [   15.985858]         72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00

      [   15.985863]         00 00 01 68

      [   15.985866] sd 0:0:0:0: [sda]

      [   15.985867] Add. Sense: No additional sense information

      [   15.985868] sd 0:0:0:0: [sda] CDB:

      [   15.985869] Read(10): 28 00 00 00 01 68 00 00 08 00

      [   15.985874] end_request: I/O error, dev sda, sector 360

      [   15.986726] Buffer I/O error on device sda, logical block 45

      [   15.987594] ata1: EH complete

      [   15.987600] sd 0:0:0:0: rejecting I/O to offline device

      [   15.989243] ata1.00: detaching (SCSI 0:0:0:0)

      [   15.991348] sd 0:0:0:0: [sda] Synchronizing SCSI cache

      [   15.991380] sd 0:0:0:0: [sda]

      [   15.991383] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK

      [   15.991385] sd 0:0:0:0: [sda] Stopping disk

      [   15.991392] sd 0:0:0:0: [sda] START_STOP FAILED

      [   15.991394] sd 0:0:0:0: [sda]

      [   15.991396] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK