3 Replies Latest reply on Apr 18, 2015 2:20 AM by Richard_H

    Unable to SSH with Edison

    anonymouse64

      Hello all,

      I have an Intel Edison, and I have flashed the most recent firmware to the device, then I have configured the device with

      configure_edison --setup

      I am then able to connect to the internet with curl, etc. So I know the Edison is successfully connecting to the Internet. I can also go the the device's IP address in the web browser and get the normal Device Information page.

       

      Now, when I go to SSH into the device from either the host computer the Edison is connected to on the same network or even another device on the network, I get a Connection Refused error.

      I have confirmed that my SSH client works (PuTTY on windows) and even tried using another Linux device (Raspberry Pi) to SSH into the Edison with no luck. I have reflashed the Edison, I have reconfigured the WiFi with

      configure_edison --setup

      When I attempt to even do

      ssh localhost

      over the serial console on the Edison, it also says Connection Refused. I am wondering if there is some setup step to configure SSH access I have missed?

       

      Any assistance with this would be much appreciated.

      Thanks,

      Ian

       

      Message was edited by: Ian Johnson (forgot to add in other commands)

        • 1. Re: Unable to SSH with Edison
          JPMontero_Intel

          Hi anonymouse64,

           

          When you are trying to connect to the SSH address are you getting the PuTTY Security Alert message? You need to agree with it in order to get in. Also are able to ping the board's address? You can also check if the IP address you are using is the right one by using the ifconfig wlan0 command.

           

          Regards,
          JPMontero_Intel

          • 2. Re: Unable to SSH with Edison
            anonymouse64

            Hi JPMontero_Intel,

            I do not get any kind of Security Alert message. The following is the only error I get:

            putty error.png

             

            Do I need to have SSH keys on my machine?

             

            Additionally, this is the output of ifconfig wlan0:

            wlan0    Link encap:Ethernet  HWaddr fc:c2:de:3e:23:b0

                      inet addr:192.168.1.233  Bcast:192.168.1.255  Mask:255.255.255.0

                      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                      RX packets:52 errors:0 dropped:0 overruns:0 frame:0

                      TX packets:43 errors:0 dropped:0 overruns:0 carrier:0

                      collisions:0 txqueuelen:1000

                      RX bytes:8601 (8.3 KiB)  TX bytes:5944 (5.8 KiB)

             

            I have confirmed I am using the correct IP address, and that the machine responds to pinging over the network.

             

            Ian

            • 3. Re: Unable to SSH with Edison
              Richard_H

              I had the same trouble after upgrading to the latest image.  I think there's a defect in the latest configure_edison script - although I had a password set, the system did not recognize it had been done.  E.g., pulling up the webpage for the device showed that a password had not been set.

               

              I did these steps to fix this:

              1. Edit /lib/systemd/system/sshd.socket and comment out the USB0 bind statement.  This will enable SSH to bind to all network interfaces.  This step might also be done automatically by the next step; I did it manually as part of an earlier attempt.  It's needed regardless.
              2. configure_edison --password - this seems to have executed whatever step had failed to complete during the initial device setup.  It indicated that it was enabling SSH on wlan0.
              3. shutdown -r now - The above change is apparently not immediately effective.

               

              Note that with the USB0 interface active, some folks have had issues with the addresses landing in the same subnet, and they needed to readdress the USB0 interface.  I didn't run into that, but have found a thread here discussing it.