3 Replies Latest reply on Apr 3, 2015 12:08 AM by nniles

    bitbake edison-image fails on qemu for ww05-15

    nniles

      I am trying to build edison-image for ww05-15 from source on Ubuntu 12.04 LTS (x86_64, running in VirtualBox), and it fails on qemu.

       

      ERROR: Function failed: do_compile (log file is located at xxxxxxxxxx/Edison/ww05-15/edison-src/build/tmp/work/x86_64-linux/qemu-native/1.7.0-r0/temp/log.do_compile.29478)

      ERROR: Logfile of failure stored in: xxxxxxxxxxx/Edison/ww05-15/edison-src/build/tmp/work/x86_64-linux/qemu-native/1.7.0-r0/temp/log.do_compile.29478

      Log data follows:

      | DEBUG: Executing shell function do_compile

      | NOTE: make -j 4

      |   LINK  mipsel-softmmu/qemu-system-mipsel

      | target-mips/translate.o: file not recognized: File truncated

      | collect2: ld returned 1 exit status

      | make[1]: *** [qemu-system-mipsel] Error 1

      | make: *** [subdir-mipsel-softmmu] Error 2

      | ERROR: oe_runmake failed

      | WARNING: exit code 1 from a shell command.

      | ERROR: Function failed: do_compile (log file is located at xxxxxxxx/Edison/ww05-15/edison-src/build/tmp/work/x86_64-linux/qemu-native/1.7.0-r0/temp/log.do_compile.29478)

      ERROR: Task 1949 (virtual:native:xxxxxxxxxxxxx/Edison/ww05-15/edison-src/poky/meta/recipes-devtools/qemu/qemu_1.7.0.bb, do_compile) failed with exit code '1'

       

      I don't actually care about qemu (as far as I know).  In fact, it would be nice if there were a succinct guide on how to build a bare-bones Yocto image for Edison (the Yocto documentation appears rather dense and seems to have a very steep learning curve).  I don't need any multimedia, nodejs, wyliodrin, or even arduino.

       

      Thanks,

        • 1. Re: bitbake edison-image fails on qemu for ww05-15
          JPMontero_Intel

          Hi nniles,

           

          Are you building the default Edison image or are you creating a custom one? If you are having problems learning with the Yocto documentation, maybe you can go with the graphic user interface, it is easier to add and remove packages from the image and could be helpful to understand how it works.  I have not tested it with the Edison image yet, but perhaps you could give it a try. In this message there is a small guide I followed for the Quark image. Also make sure you are giving the Virtual machine enough resources for the build. Regarding your error, it seems the file is corrupted or incomplete. If you build a previous image in the same build directory, I’d suggest you to start the image from scratch instead of cleaning the previous build.

           

          Regards,
          JPMontero_Intel

          • 2. Re: bitbake edison-image fails on qemu for ww05-15
            nniles

            JPMontero_Intel,

             

            I am following the BSP Users Guide, section 2, and just attempting to build the default image for now.

             

            I also tried Hob, but even when I unselected the qemu package, it still got pulled in somehow. 

             

            It's not so much that I'm having "problems learning with the Yocto documentation," but that I'm trying to stay focused.  I'm not trying to learn Yocto - I'm trying to use the Edison.

             

            Everything in this build is from scratch, from installing the OS on a new VM to downloading and building from the newest Edison source.  I gave it 40GB of space, and there's still over 20GB available.  If "that file" (target-mips/translate.o) is corrupted or incomplete, can I replace it somehow without starting over from scratch?

             

            Thanks for your response!

            • 3. Re: bitbake edison-image fails on qemu for ww05-15
              nniles

              I did some thinking after my last post, and decided to find the offending file and just delete it, which seems to have worked.

               

              After some more research, I believe the best way to handle this sort of issue is just clean the recipe that is having the problem.  It's happened to me again with a different recipe because VirtualBox seems to have problems coming back from screen blanking (which I have now disabled...).

               

              bitbake -c clean qemu-native

               

              And then resume building the image:

               

              bitbake edison-image

               

              To be specific, I deleted the following file:

               

              .../edison-src/build/tmp/work/x86_64-linux/qemu-native/1.7.0-r0/qemu-1.7.0/mipsel-softmmu/target-mips/translate.o

               

              Thanks again!