2 Replies Latest reply on Mar 29, 2015 2:24 PM by Iron_Attorney

    Eclipse IDE unable to detect 64bit Java

    Iron_Attorney

      Ok, I've already posted a discussion about my problems with the Arduino IDE, but I'm having issues with eclipse aswell, and I figured that wants it's own seperate deiscussion.

       

      When I try to open eclipse using the devkit-launcher batch file (as recommended in a getting started tutorial), I get this error message:

      Detected Java 32-Bit. The Intel(R) IoT Developer Kit supports only Java 64-Bit.

      Please install Java 64-Bit from http://www.oracle.com/technetwork/java/javase/do

      wnloads/index.html

      Press any key to continue . . .

      When I try to open eclipse from the eclipse.exe file, I get a really long error message which I can't copy and paste. Within this error message though.

       

      I have already downloaded the latest 64bit java, but I have been struggling with where to put it. One tutorial sugested having it as close to C: as possible, so I have created a java folder straight on C drive. That hasn't worked. On reading throught the error message genereated by eclipse.exe, it mentions a directory for java:

       

      C:/windows/programdata/oracle/java/javapath/

       

      This contains a 3 .symlink files. I've never heard of these, but they seem to be like shortcuts to the java, javaw and javaws files. When I right click and "Open file location", it takes me to the pre-existing java folder which contains jre1.8.0_31 (Java SE 8, update 31). The 64 bit copy I just downloaded was jre1.8.0_40. Is Java SE 8u31 likely to be 32bit? If so, how can I change the shortcuts to link to my new version? I've tried opening the proporties of the .symlink files, and the shortcut's target is greyed out. Am I even barking up the right tree here?

       

      I am thourally thrown by all of this! And rather frustrated as I can get neither Arduino or Eclipse to work, and I have some awesome programs ready to be uploaded!

       

      Thank you in advance for any help anyone can offer

       

      Pete