3 Replies Latest reply on Mar 26, 2015 9:32 AM by ForumMigrationAdmin

    IoT Dev Kit and unable to see my device in the Device page

    ForumMigrationAdmin

      I have the Edison IoT dev kit and trying to use the Cloud Analytics platform.

      "iotkit-admin test" worked and my Edison is activated successfully using the code in the account settings page.

      From the Dashboard it says I have 1 device (now 2 as I tried reactivating it with a new ID) but when I click the Devices button or go to the Devices tab there are no devices listed.

      If I go to Charts or Control I can see the device (now 2) and if I try to Add a Device manually using the ID from the Edison it says that this device is already registered. If I try to activate it again it says that it is already activated.

      So it seems to be an issue in the Device page on the Cloud.

      Ideas???

      Ignore the dates as these are not consecutive commands but show the issue.

      root@edison:/etc# iotkit-admin test
      2014-11-07T00:03:29.248Z - info: Trying to connect to host ...
      2014-11-07T00:03:34.072Z - info: Connected to dashboard.us.enableiot.com
      2014-11-07T00:03:34.077Z - info: Environment: prod
      2014-11-07T00:03:34.078Z - info: Build: 0.10.6

      root@edison:/etc# iotkit-admin activate XXXXXXX
      2014-11-07T00:52:24.307Z - info: Activating ...
      2014-11-07T00:52:29.570Z - error: Activation Rejected:  {"code":1409,"message":"Device already exists"}  --> error
      2014-11-07T00:52:29.577Z - error: Error in the activation process ... 300

      root@edison:/etc# iotkit-admin register temp temperature.v1.0
      2014-11-07T00:48:07.869Z - info: Starting registration ...
      2014-11-07T00:48:07.982Z - error: Device has not been activated, and activation code has not been set - exiting
      root@edison:/etc#

        • 1. Re: IoT Dev Kit and unable to see my device in the Device page
          ForumMigrationAdmin

          I had the same problem, I did this:

           

           

          1. Dashboard>Devices>Trash icon (Delete all of them)

           

           

          2. Reboot Edison: reboot

           

           

          3. In this order:

           

           

            systemctl status iotkit-agent

            systemctl stop iotkit-agent

            iotkit-admin initialize

          Dashboard>MyAccount>Details>Refresh Activation Code

           

           

            iotkit-admin activate «activation_code»

            systemctl start iotkit-agent

          Now the "components" the Dashboard>MyAccount>Catalog , should match:

           

           

            iotkit-admin catalog

          Maybe Intel should have more "components", however you can now register it:

           

           

            iotkit-admin register <<yourVar>> <<component_id>>

          Send Info :

           

           

            iotkit-admin observation <<yourVar>> <<yourValue>>

          View Info in Dashboard>Charts>Device>Component

           

           

          Would be great to have other skins to view info and ways to manipulate data before representation!!

           

           

          Hope it works for you

          • 2. Re: IoT Dev Kit and unable to see my device in the Device page
            ForumMigrationAdmin

            When I looked after the weekend the devices were there!

            Maybe a delay to getting them added I thought. Wrong. I deleted the devices and generated new IDs and then re-activated and it was instant. All good now whatever the problem was.

            I have now installed the agent onto my gateway server in my lab which was already monitoring temperature and simply added one line "/usr/local/iotkit-agent/iotkit-admin.js observation temp ${t}" to the end of the script and now all the temperatures are getting sent up to the analytics and I can graph, alert and everything. Neat.

            It would be nice if I could set the alerts to go to other emails that were not "users". I have a email->SMS service that I use so I need to add a custom email address for the alerts.

            • 3. Re: IoT Dev Kit and unable to see my device in the Device page
              ForumMigrationAdmin

              typically you would register new components via the iotkit-agent (either via UDP or via TCP).

              Note: if you use

              iotkit-admin register <<yourVar>> <<component_id>>
              

               

              you effectively bypass the iotkit-agent. Hence you'd have to restart the agent in order to pick up this new component.

              Also:

              iotkit-admin initialize
              

               

              might not be sufficient. If you have already had something running you might also have to run


              iotkit-admin reset-code
              

               

              before