5 Replies Latest reply on Oct 16, 2009 5:09 AM by Makatini

    DP45SG Express Bios Update Fails

    mbranger

      New computer...DP45SG...with Bios 0088.  Trying to update bios to version 0188 from Windows.  All seems to work fine, reboots and starts process.  Wait 15-20 minutes still not second reboot after supposed update.  Have to manually turn off and restart.  After Windows starts; screen states bios update was successful. However, bios is still version 0088.   WHAT IS WRONG?

       

      System…

      Windows Vista Business 64 bit

      Intel Core 2 Quad Q9650

      8 GB 1333/DDR3

      ATI Radeon HD 2400

       

      I can not find any assistance related to this issue

        • 1. Re: DP45SG Express Bios Update Fails
          yoopertech

          I had the same problem.This worked for me,  take the bios download move it to your desk top  and  open and run it from there.

          • 2. Re: DP45SG Express Bios Update Fails

            Glad to see I am not alone in this. I am trying to flash the bios on my DP45SG mobo and get the same result!

            Downloaded the .exe file to the desktop. Run the update file. System shuts down, restarts and just sits. Come

            back 10-15 min later and restart and system says update sucessful. Check Bios SN and find ver 0088. No change.

            System

            DP54SG main board

            QX9750 processor

            4 gig patriot ram

            1 ATI XFX HD4850 video cards

            Antec Signature 850 pws

            Cool Master full size ATX case

            2 WD 750 gig hard drives

             

            The orriginal reason for this build was to go crossfire. I have been told that the bios update was required. I have

            already installed the newest chipset update available from the INTEL download center.

             

            Where do I go from here?

            • 3. Re: DP45SG Express Bios Update Fails
              mbranger

              After trying several things I found the fix...

              1. Get a new or clean USB stick 2mb will do.

              2. Make the stick bootable; the bios instruction page on the Intel site give directions (I dowmloded the HP make a bootable USB drive software for free)

              3. Download the USB Bios file from Intel Ithe site states the correct version) to your computer.

              4. Extract and copy files to the USB.

              5. Before going further; you may have to reboot; get into the bios; make sure it is set to boot from USB

              6. Save and exit bios; let windows complete load.

              7. Shut down computer.

              8. Put USB in computer

              9. Turn on power.

              10 you will get a message at startup; boot location; presss corrext ket to boot from USB.

              11. I will boot; and look like old DOS boot.

              12. Here the trick; the Intel instruction are wrong!

              13. Follow them; but type IFLASH2 xxxxxxx NOT IFLASH xxxxxx [NOTE THE TWO]

              14. Again, follow Itel instructions except for 13. above.

              15. Sit back; the screen will go blank; do not touch a thing; it will come back in 20-30 seconds with progress on screen.

              16. The system reboots upon completion.

              This works --- I used the latest version 121

              ========================================

              Hope this helps.

               

               

              13.

              • 4. Re: DP45SG Express Bios Update Fails
                yoopertech

                If your system is stable ,you don't need to update your bios for crossfire. I was running  two HD4830 in crossfire, on first released bios .Make sure to attach  the brigdes between the cards. However my system runs better with the current bios and you have more features.  If you have problems with the bootable drive  bios update, which I did. try the EB.EXE. again.  First SAVE  the file to your downloads ,then move it to desktop to open it and let it run.   It actually is a soild board once you get it running right. Don't give up on it.

                • 5. Re: DP45SG Express Bios Update Fails
                  Makatini

                  I found a similar problem with DP45SG, Bios 0088. I tried all methods of updating the BIOS and none of it worked. After contacting Intel support they suggested that I patch it to an inbetween version (0093), then try to upgrade to 0121. The upgrade to 0093 worked but the upgrade to 121 still failed in the same unspectacular way. I then considered the difference between the updates, mainly the iflash utility is replaced by iflash2 for the 0121 update. The difference in behaviour is that iflash upgrades immediately and iflash2 reboots your computer and then upgrades the bios. Since this motherboard contains a USB mouse and keyboard, booting up from USB and appllying the patch does not work, because when Iflash2 reboots the computer to upgrade it can't read the bios file from the usb flash disc.

                  Solution:

                  1. create a bootable USB flash drive
                  2. copy the iflash2 and .bio file onto USB
                  3. take a blank CDRom and copy only the .bio file to it.
                  4. Insert CD into CD Drive
                  5. boot up with the USB drive
                  6. run iflash2.exe /pf *****.bio

                   

                  now when it reboots it will read the .bio file from the CD and will upgrade the bios.

                   

                  p.s. There is also an iso image available to upgrade the BIOS. Don't bother, it does not contain USB drivers. When you boot up it prompts you to press Enter or type YES but you are unable to because the USB Keyboard does not work.