6 Replies Latest reply on Apr 8, 2015 2:11 PM by CMata_Intel

    Can't revert back to BlueZ5.24 after uninstalling BlueZ5.29

    oneb1got

      Hi everyone,

       

      I needed to use gatttool but it doesnt seem to have been included in the edison bluez5 package so I took it upon myself to download bluez5.29 from the bluez website.

       

      after doing a make install, bluetoothctl didnt work at all. it would freeze and not allow any sort of keyboard input.

      This worried me so I tried to go back to 5.24 but now im am getting

       

      Installing bluez5 (5.3-r0.0) to root...
      > Collected errors:
      >  * check_conflicts_for: The following packages conflict with bluez5:
      >  * check_conflicts_for: bluez4 *
      >  * opkg_install_cmd: Cannot install package bluez5.

       

      I have already run make clean and make uninstall from the 5.29 directory.

      I have also tried `opkg remove --force-depends bluez4` but no packages are removed, in fact there is no such packages found that have bluez4 in opkg.

       

      How can I get bluetooth working again and if possible also have gatttool?