4 Replies Latest reply on Apr 5, 2015 8:15 PM by sglee367

    Using Galileo with a SD card DISABLES Serial2 !!!

    sglee367

      hi, everyone!


      Firstly, I'm a user of Galileo Gen2. and now working on a project that must use both UART ports (UART#0 from Digital I/O pin 0,1 and UART#1 from pin 2,3)

      Today I feel very frustrated finding out this problem.


      I found that pin 3 does not transmit any data.

      Although it sets HIGH (5V) after calling Serial2.begin(baudrate), it does not make any responses to my calling Serial2.print(somedata) or Serial2.write(somedata).

       

      Therefore, I tried with the simplest code,

      ----------------------------------------------

      void setup() {

        Serial1.begin(500000);

        Serial2.begin(19200);

      }

      void loop() {

        Serial1.write("Test");

        Serial2.write("Test");

        delay(100);

      }

      ----------------------------------------------

      ,which also gave me the same result.

       

      After other frustrating tests, I finally found that the code itself was not wrong at all. Simply removing the SD card, booting again, and uploading the exactly same code again gave me the perfect, originally expected result.

       

      Well, anyone know solution to this problem??

      Although I can just upload codes every time I pull out the DC adapter and plug it in again, for this project, I'm not going to use Galileo for my next projects if I should keep doing that.

      Maybe I should try with other versions of the images first.

       

      Thank you so much for your any comments, in advance.

      Have a nice day!