3 Replies Latest reply on Mar 26, 2015 12:04 PM by Salem_Intel

    PCIe MPS(Max Payload Size) in intel server

    HappyMan

      Hi, everyone

       

      My server has a nic card of which PCIe MPS(max payload size) capability is 1024 bytes.

      However, the MPS of the nic card negotiated is 128 bytes.

      We search for the reason and we found that the MPS capability of the intel PCIe bridge connected with our nic is 128 bytes.

      Our OS is linux.

      Please let me know if there is any method for modifing the MPS of our nic?

      If the MPS of the bridge is 128bytes, is the MPS of the nic connected to it alway under 128bytes?

       

      Thanks in advnace.

      J.Hwan Kim

        • 1. Re: PCIe MPS(Max Payload Size) in intel server
          Dan_Intel

          Hi there,

           

          Please let us know the model number for the server system and the network card you have in order to provide further assistance on your inquiry.

          • 2. Re: PCIe MPS(Max Payload Size) in intel server
            HappyMan

            Thanks for reply.

            I'm sorry that there are mistakes in previous my post.

            The negotiated MPS is 256 bytes.

            The server model is S2600CP and the NIC is FPGA-based board made from Xilinx.

            The nic is a customized board, not commercial NIC.

             

            Thanks

            • 3. Re: PCIe MPS(Max Payload Size) in intel server
              Salem_Intel

              Hi!

               

              As we understand, instead of negotiating at 256 bytes, the Xilinx* NIC card on the Intel® Server Board S2600CP does at just 128 bytes.  If we infer correctly, although the BIOS of the Intel® Server Board S2600CP does not feature an option to manually alter MPS settings, based on the fact no Xilinx card is listed among the officially validated hardware (click here for the complete list), we recommend the following:

               

              1. Set the PCI Configuration/Memory Mapped IO Size BIOS option to Auto; save, reboot and test.  If the situation still continues, try forcing it to 256:

              MPS.JPG

              2. Test with the BIOS default settings if the Xilinx still does not negotiate at 256b.

               

              3. Ensure the BIOS/firmware of your Intel® Server Board S2600CP is at the latest (click here); otherwise, please, check with the NIC card manufacturer.