2 Replies Latest reply on Mar 29, 2015 8:34 PM by burrsutter

    Edison Ubilinux Static IP

    burrsutter

      What are the steps to setup a static IP address on Ubilinux for the Edison's built-in Wifi?

       

      I have tried the steps provided by SparkFun https://learn.sparkfun.com/tutorials/loading-debian-ubilinux-on-the-edison#enable-wifi

      Overall, the Edison, with its new IP address, allows me to ssh in from another machine (e.g. Mac) BUT, the Edison itself can not see the Internet.  Things like "apt-get upgrade" or "apt-get upgrade" never complete.  "ping www.google.com" never returns.  It seems that DNS is not properly configured, likely my error, but I am not sure where I went wrong.

       

      Errors from "apt-get"

      Failed to fetch http://security.debian.org/pool/updates/main/l/linux/linux-libc-dev_3.2.65-1+deb7u2_i386.deb  Could not resolve 'security.debian.org'


      I have also tried to replicate the settings from Raspbian.


      /etc/network/interfaces

       

      # interfaces(5) file used by ifup(8) and ifdown(8)

      auto lo

      iface lo inet loopback

       

      #auto usb0

      iface usb0 inet static

          address 192.168.2.15

          netmask 255.255.255.0

       

      auto wlan0

      iface wlan0 inet manual

      wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

      iface default inet static

       

      address 192.168.2.40

      netmask 255.255.255.0

      gateway 192.168.2.1

       

      # And the following 4 lines are for when using hostapd...

      #auto wlan0

      #iface wlan0 inet static

      #    address 192.168.42.1

      #    netmask 255.255.255.0


      /etc/wpa_supplicant/wpa_supplicant.conf

       

      ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

       

      network={

              ssid="myssid"

              scan_ssid=1

              psk="thepassword"

              key_mgmt=WPA-PSK

      }

        • 1. Re: Edison Ubilinux Static IP
          JPMontero_Intel

          Hi burrsutter,

           

          Your configuration in /etc/network/interfaces looks good. Make sure the IP address you are trying to use is not assigned to another device and that it is under the range of addresses in the router. You can try is to assign the MAC address of the Edison to a specific IP address in the router. This will make the router assign the same address to the device all the time. If this is an option for your project I'd suggest you to try it. If this does not work i'd suggest you to ask in in ubilinux forums in EmutexLabs.     

           

           

          Regards,
          JPMontero_Intel

          • 2. Re: Edison Ubilinux Static IP
            burrsutter

            I believe I have discovered my problem.

             

            My router (gateway) was serving up 192.168.2..* addresses.

             

            The Edison is already using 192.168.2.* for its USB interface. 

            1 of 1 people found this helpful